INIT boot problem

Francois fswanepoel at
Thu Jan 11 05:55:12 PST 2001

Hi all
I have been struggling with this for 3 days now and have no other option
than to ask the list.
I compiled LFS on my Mandrake 7.2 system. This worked fine and I can
reboot into my LFS and use it.
Now I wanted to copy LFS onto another system (Olivetti P/100 En, 32Mb
Ram). These are the steps I followed
1. Got tomsrtbt disk, booted off it, got the networking going.
2. Partitioned the harddisk and ran mkswap and mke2fs (Linux native +
3. tarred lfs from MD system ( tar -czvf /tmp/lfs.tar.gz ./boot ./etc
../lib ./sbin ./usr ./bin ./home ./mnt ./root ./tmp ./var)
4. Mounted HD partition, snarfe'd (ftp'd) it to the new system and
extracted the tar file.
5. Created /proc and /dev.
6. Copied /dev from tomsrtbt onto HD filesystem (/mnt/dev) using cp -dpR
/dev /mnt
7. Edited /mnt/etc/lilo.conf and added lfs kernel file (See lilo.conf
8. Edited /mnt/etc/fstab and made sure /dev/hda1 / ...... ,swap
partition and /proc is correct.
9. Ran chroot /mnt lilo -v . All seemed to be ok so far.
10. Rebooted and crossed my fingers........

It booted the lfs kernel and there were no errors reported.
The problem is that the boot process gets to "INIT: version 2.78
booting" and hangs.
I have also read through "The Linux Bootdisk HOWTO" and tried everything
in Ch.7, but to no avail.

If I can get this working, a whole lot of NT servers will be put on the
endagered species list.

Anybody have any ideas?

Thank you

Unsubscribe: send email to alfs-discuss-request at
and put unsubscribe in the subject header of the message

More information about the alfs-discuss mailing list