Fwd: Re: glibc 2.2.4 compile error

Gerard Beekmans gerard at linuxfromscratch.org
Mon Jan 28 10:50:52 PST 2002

----- Forwarded message from Sascha Herrmann <Sascha.Herrmann at web.de> -----

From: Sascha Herrmann <Sascha.Herrmann at web.de>
To: gerard at linuxfromscratch.org
Subject: Re: glibc 2.2.4 compile error
Date: Mon, 28 Jan 2002 18:50:34 +0000
Delivered-To: gerard at localhost.gwaihir.linuxfromscratch.org
Delivered-To: gerard at linuxfromscratch.org
X-Mailer: Sylpheed version 0.6.3 (GTK+ 1.2.10; i586-pc-linux-gnu)
X-UIDL: Q:W"!+Id"!aUn"!NI(!!

HI gerard,

during nALFS i discovered the same fault you were talking about erlier (see down), and i tried a little and found that the problem was nALFS didn´t unset the compilerflags during compiling mawk static! So mawk produces Segmentation Faults!
I tried this with using:

export CFLAGS="-s -Os -fomit-frame-pointer -Wall  -march=i586 -funroll-loops"
export CFLAGS="-s -O2 -fomit-frame-pointer -Wall  -march=i586 -funroll-loops"

When doing this step by hand as you suggest, everything work fine.

Maybe you can put this comment to the mailinglist, as i´m not allowed to post!

with best regards Sascha Herrmann

On Fri, Sep 14, 2001 at 12:07:28AM +0200, zbx at grounder.net wrote:
> When I tried to make glibc-2.2.4 I got the following error message:
> { while read lib version setname; do \
>     test -z "$setname" || echo "$lib : $setname"; \
>   done < /usr/src/sources/g/glibc-build/soversions.i; \
>   cat Versions.def \
>   | sed '/^[    ]*#/d;s/^[      ]*%/#/' | gcc -E -undef -I/usr/src/sources/g/glibc-build -Iinclude -include /usr/src/sources/g/glibc-build/config.h -x assembler-with-cpp - | sed '/^[  ]*#/d;/^[       ]*$/d'; \
> } | LC_ALL=C mawk -f scripts/firstversions.awk > /usr/src/sources/g/glibc-build/Versions.allT
> make[1]: *** [/usr/src/sources/g/glibc-build/Versions.all] Error 139
> make[1]: Leaving directory `/usr/src/sources/g/glibc-2.2.4'
> make: *** [all] Error 2
> In glibc-build I found a file Versions.allT which is empty. 
> My actual system uses glibc 2.2.2 and kernel 2.4.2 on something like a 
> debian system. I tried it on another system using glibc 2.1.3 and kernel 
> 2.2.17 with the same error.
> How to solve the problem?
All signs point to a problem with the mawk program on your LFS system.
Go back to chapter 5, reinstall it. After the reinstallation, run "ldd
$LFS/usr/bin/mawk" and make sure it's statically linked (it'll tell you
if it is or isn't).

----- End forwarded message -----

Gerard Beekmans

-*- If Linux doesn't have the solution, you have the wrong problem -*-
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe alfs-discuss' in the subject header of the message

More information about the alfs-discuss mailing list