checksum verification in nALFS

Neven Has haski at sezampro.yu
Sat Oct 12 08:52:02 PDT 2002

On Sat, Oct 12, 2002 at 12:13:34AM +0200, Vassili Dzuba wrote:
> > I know this is another big, profile_breaker change (something for
> > syntax 4.0, but hey, we already got used to that ;), but I actually
> > like this solution. At least these 5 minutes. :) I might change my
> > mind in another 5.
> When do you plan to introduce this 4.0 version ?

I don't, there isn't 4.0. :)

Just wanted to say that if we were to change the syntax of <unpack> in
the way that is not compatible with the current syntax, we will have to
introduce it.

> Well, XML is not inherently declarative, imho, and i think that
> <unpack> is probably more intuitive for a newbie to ALFS.

When it comes to only unpacking yes, I agree.

But I don't think that <checksum> belongs in <unpack>. It doesn't have
anything to do with unpacking. The fact that it's usually used before
unpacking, shouldn't be important.

Since I forgot about <reference>, I don't think now that we should have
a separate <checksum> (or <verify>) neither, because we _have_ to have
one tied to unpacking (because of the <reference>).

So the only thing left could be something like this:


This is just a rough structure, without going into naming of the
elements inside <archive>.

The reason I prefer this structure is because both checking and
unpacking are about the archive.

It does contain <unpack>, so it should be clear when it comes to
unpacking. And also, when it's left out, it's clear that the archive is
just being checked.

The problem could be where to put destination. Putting it as an element
inside <unpack> would mean more writing. And naming it
<unpack_destination>, or something like that, is too ugly IMHO.

Anyway, we really need more opinions on this. It would help. :)

> We could also replace <checksum> by <digest>, which is the name used
> in the openssl documentation.

Yeah, md5sum man page also mentions "digest".


Unsubscribe: send email to listar at
and put 'unsubscribe alfs-discuss' in the subject header of the message

More information about the alfs-discuss mailing list