manuel at linuxfromscratch.org
Mon May 8 09:44:13 PDT 2006
El Lunes, 8 de Mayo de 2006 01:09, Jeremy Byron escribió:
> - DEF_OPT_LVL to DEV_OPT_MODE for consistency
> - changed all over the place
> - Zlib to defOpt_fPIC
> - With the nice confirmation page, "zlib Zlib" isn't descriptive
> - Showing the inheritance in the override readout is moreso
> - Plus, if you have 5-10 packages that all need "-fPIC",
> it wouldn't make sense to have 5-10 identical files for each
> package or have such as "fooPkg Zlib" in the override file..
Naming it defOpt_fPIC due that defOpt is at this moment the name for "-O3
-pipe" mode. Maybe the defOpt file should be renamed to "O3-pipe"
> - Collected the if structures and such in defOpt_fPIC into a loop/case
Good. The looks more clean.
Many thanks for this and the MAKEFLAGS patch. I will commit both in one-two
Manuel Canales Esparcia
Usuario de LFS nº2886: http://www.linuxfromscratch.org
LFS en castellano: http://www.escomposlinux.org/lfs-es http://www.lfs-es.com
More information about the alfs-discuss