jhalfs update for LFS 7.9

Robert Duffy rubbish at utanet.at
Fri May 6 03:09:29 PDT 2016


On 2016-05-06 11:27, Pierre Labastie wrote:
> On 06/05/2016 09:27, Robert Duffy wrote:
>> On 2016-05-04 18:43, Pierre Labastie wrote:
>>> On 04/05/2016 17:53, Robert Duffy wrote:
>>>> Hello!
>>>>
>>>> I tried last jhalfs with the current LFS book 7.9 on a default and
>>>> updated 64-bit Debian 7 host system and got this error. Does anybody
>>>> know how to fix this error?
>>>>
>>>> Building the system...
>>>> make[1]: Entering directory `/mnt/lfs/jhalfs'
>>>> -------------------------------------------------------------------------------- 
>>>>
>>>>
>>>> mk_LUSER
>>>> You are going to log into the user account lfs
>>>> sudo requires a password
>>>> make: Entering directory `/mnt/lfs/jhalfs'
>>>> -------------------------------------------------------------------------------- 
>>>>
>>>>
>>>>  Building target 039-gcc-pass2
>>>>  [++++++++\make: *** [039-gcc-pass2] Error 2 ] 17
>>>> min. 8 sec
>>>> make: Leaving directory `/mnt/lfs/jhalfs'
>>>> make[1]: *** [mk_LUSER] Error 2
>>>> make[1]: Leaving directory `/mnt/lfs/jhalfs'
>>>>
>>>> ERROR: Error 2 at common/common-functions line 39!
>>>>
>>>>
>>>> <jhalfs-trunk> exit
>>>>
>>>> make: *** [all] Error 2
>>>>
>>>> Btw: The LFS book 7.6 works fine with last jhalfs.
>>>>
>>>> Sincerely,
>>>> Robert Duffy
>>> Hi,
>>>
>>> I've tested jhalfs several times with LFS-7.9 and haven't had any 
>>> error.
>>> What amazes me is that it starts at gcc pass2. Had you run make before?
>>>
>>> I think the error occured during gcc build (or install). Have you 
>>> looked
>>> at /mnt/lfs/jhalfs/logs/039-gcc-pass2?
>>
>> Hello Pierre and Bruce!
>>
>> Thank you for your hints.
>>
>> glibc >=2.14 is needed for lfs 7.9 - I used glibc 2.13 :-( . So I 
>> installed a fresh 64-bit Debian 8.4 host system and now it works.
>>
>> Btw: I'm wondering why the version check on startup passes even with 
>> glibc 2.13.
>>
> The "host system requirements" page for LFS-7.9 says the minimum 
> required version is 2.11. So jhalfs compares the host version to 2.11. 
> Where have you seen that it needs 2.14? I may need to update jhalfs to 
> look at that source.

Hello Pierre!

It was your hint. I have seen it in the 
/mnt/lfs/jhalfs/logs/039-gcc-pass2 logfile.

Btw: The host system I now use has glibc 2.19.

Thanks again!

Sincerely,
Robert Duffy


More information about the alfs-discuss mailing list