[alfs-discuss] Segfault when make script tries to chroot

Pierre Labastie pierre.labastie at neuf.fr
Mon May 14 13:07:11 PDT 2018


On 14/05/2018 12:36, THEMINER _TV wrote:
> Oh yeah
> I forgot to mention that i want to build LFS-8.0 on jhalfs-2.4
> 
> 2018-05-14 12:33 GMT+02:00 THEMINER _TV <tobigames200 at gmail.com
> <mailto:tobigames200 at gmail.com>>:
> 
>     Hello!
>     I compiled LFS 4 times myself and its worring that i cant automate it.
>     Then i've seen alfs and tried it out after this tutorial:
>     https://tinyurl.com/ycut44kw

This is quite old. Hope you have used the book instructions for creating and
mounting the LFS partition... Also, I hope you have used the ncurses menu.
There is a CHEATSHEET in the source directory of jhalfs, which may be used to
replace the part about the settings.

>     It worked but after 067-kernfs it asked for my password and crashed and
>     said : /tools/bin/bash : segfault "some random number"core dumped
>     some random nuber changes when i rerun the make.

Can you run /tools/bin/bash from the host (without chrooting)?
If it works, then try to copy/paste the chroot command from the book, and see
if it works.

If all works, then try "make -C /mnt/build_dir/jhalfs"

if /tools/bin/bash does not work from the host, there was something wrong when
building bash. Have a look at the logs (in /mnt/build_dir/jhalfs/logs). But if
you have not used optimization other than parallel make, this should be OK.

if /tools/bin/bash works from the host, but not when running the chroot
command, that may be a problem with the link /tools->/mnt/build_dir/tools.
Or maybe the partition was not mounted correctly.

> 
>     Do you have any idea how to solve this problem?
> 
>     I am using a system like this:
>     CPU : Core2Duo 2 at 3.16 Ghz
>     RAM: 4 GB 1600 Mhz
>     OS: Linux Mint 18.3 64 bit
>     OSĀ  HDD: 2 TB WD Storage Green
>     LFS HDD: 128 GB Hitachi Drive
> 

Looks OK. I've tested building on Mint recently. It works.

Pierre


More information about the alfs-discuss mailing list