[alfs-discuss] Segfault when make script tries to chroot

Pierre Labastie pierre.labastie at neuf.fr
Mon May 14 13:15:54 PDT 2018


On 14/05/2018 22:07, Pierre Labastie wrote:
> On 14/05/2018 12:36, THEMINER _TV wrote:
>> Oh yeah
>> I forgot to mention that i want to build LFS-8.0 on jhalfs-2.4
>>
>> 2018-05-14 12:33 GMT+02:00 THEMINER _TV <tobigames200 at gmail.com
>> <mailto:tobigames200 at gmail.com>>:
>>
>>     Hello!
>>     I compiled LFS 4 times myself and its worring that i cant automate it.
>>     Then i've seen alfs and tried it out after this tutorial:
>>     https://tinyurl.com/ycut44kw
> 
> This is quite old. Hope you have used the book instructions for creating and
> mounting the LFS partition... Also, I hope you have used the ncurses menu.
> There is a CHEATSHEET in the source directory of jhalfs, which may be used to
> replace the part about the settings.
> 
>>     It worked but after 067-kernfs it asked for my password and crashed and
>>     said : /tools/bin/bash : segfault "some random number"core dumped
>>     some random nuber changes when i rerun the make.
> 
> Can you run /tools/bin/bash from the host (without chrooting)?
> If it works, then try to copy/paste the chroot command from the book, and see
> if it works.

Forgot to tell: if it works, do not forget to exit bash (key control+D) before
doing anything else...


More information about the alfs-discuss mailing list