[blfs-dev] LO-5.0.1.2 boost problem.

Fernando de Oliveira famobr at yahoo.com.br
Sun Sep 6 12:24:08 PDT 2015


Em 06-09-2015 16:15, Ken Moffat escreveu:
> I cannot build libreoffice-5.0.1.2 with boost_1_59 (LFS as at 1st
> September, BLFS as at 2nd September), it fails with:
> 
> [build LNK] Library/libucbhelper.so
> /scratch/working/libreoffice-5.0.1.2/workdir/LinkTarget/StaticLibrary/libpdfimport_s.a(pdfparse.o):
> In function `_GLOBAL__sub_I_pdfparse.cxx':
> pdfparse.cxx:(.text.startup+0x2b): undefined reference to
> `boost::system::generic_category()'
> pdfparse.cxx:(.text.startup+0x30): undefined reference to
> `boost::system::generic_category()'
> pdfparse.cxx:(.text.startup+0x39): undefined reference to
> `boost::system::system_category()'
> collect2: error: ld returned 1 exit status
> /scratch/working/libreoffice-5.0.1.2/solenv/gbuild/LinkTarget.mk:468:
> recipe for target
> '/scratch/working/libreoffice-5.0.1.2/workdir/LinkTarget/Executable/pdfunzip'
> failed
> make[1]: ***
> [/scratch/working/libreoffice-5.0.1.2/workdir/LinkTarget/Executable/pdfunzip]
> Error 1
> make[1]: *** Waiting for unfinished jobs....
> make[1]: *** wait: No child processes.  Stop.
> Makefile:247: recipe for target 'build' failed
> make: *** [build] Error 2
> 
> Google found various links over the years, all of which told me this
> is a problem with libboost_system.  My first guess was that perhaps
> something had caused it to not find the shared lib (although the
> message implies otherwise), so I tried making the static lib
> available, but that did not alter it.
> 
> For libboost_system I now have:
> 
> ken at jtm1 /sources/scripts/lfs-dev/git $ls -l /usr/lib/libboost_system.*
> -rw-r--r-- 1 root root 47846 Sep  6 00:54 /usr/lib/libboost_system.a
> lrwxrwxrwx 1 root root    25 Sep  6 00:54 /usr/lib/libboost_system.so -> libboost_system.so.1.59.0
> -rwxr-xr-x 1 root root 17000 Sep  6 00:54 /usr/lib/libboost_system.so.1.59.0
> 
> It takes about an hour and a half to get to this point, with my
> (multilingual) config on this machine.  Any suggestions, please ?
> 
> ĸen
> 


Sorry, Ken.


Yes. That's why I replaced with-system-boost by without-system-boost in

[http://wiki.linuxfromscratch.org/blfs/changeset/16363#file23]

{{{
@@ -408,5 +408,5 @@
              --enable-release-build=yes  \
              --enable-python=system      \
-             --with-system-boost         \
+             --without-system-boost      \
              --with-system-clucene       \
              --with-system-cairo         \
@@ -545,4 +545,10 @@

     <para>
+      <parameter>--without-system-boost</parameter>: This switch
disables use
+      of system boost, so bundled one is used, because currently, the
build is
+      broken with <xref linkend="boost"/>.
+    </para>
+
+    <para>
       <parameter>--without-system-dicts</parameter>: This switch
disables use
       of  dictionaries from system paths, so the ones installed by this
package

}}}


Searched for fixes without success. I don't know if it has yet appeared
a fix.

-- 
[]s,
Fernando


More information about the blfs-dev mailing list