[blfs-dev] Valgrind and Glibc-2.22

Pierre Labastie pierre.labastie at neuf.fr
Thu Sep 10 03:55:35 PDT 2015


On 09/09/2015 22:19, Bruce Dubbs wrote:
> Pierre Labastie wrote:
>> On 21/08/2015 22:46, Douglas R. Reno wrote:
>>> I am not sure if this affects trunk or not, but valgrind required some
>>> modification to build using glibc-2.22. The configure script does the
>>> same things that it does in glibc-2.21 before the patch is applied. In
>>> the sed in systemd, I had to substitute 2.21 with 2.22 for the package
>>> to compile properly. Modification of the patch in trunk may be
>>> required.
>
>> I just verified that. The patch for glibc-2.21 is not enough. I do 
>> not like
>> the sed in the systemd book: if an user wants to build using the 
>> current book
>> intructions, but with glibc-2.20 or 2.21, configure will fail to 
>> detect it...
>>
>> I think I'll tweak the patch for trunk.
>
> There is a ticket for that and I was going to do it as soon as I've 
> done the dependencies.  But please go ahead with the patch.
>
>   -- Bruce
>
Oops sorry, should have checked. I'll make the patch, since I need it to 
build openjdk (dunno exactly where valgrind enters the dependency chain 
for that, but it does...). I'll upload it to the repo, leaving the page 
change to you, if you agree.

Pierre



More information about the blfs-dev mailing list