[blfs-dev] Firefox dependencies

Ken Moffat zarniwhoop at ntlworld.com
Thu Sep 24 11:35:32 PDT 2015


On Thu, Sep 24, 2015 at 08:00:12PM +0300, Markku Pesonen wrote:
> Ken Moffat wrote:
> > Well, I've now rebuilt mine without system cairo for 7.8.  Just to
> > make sure that we're all singing from the same sheet - even though
> > I'm no longer telling it to enable system cairo, ldd shows that
> > /usr/lib/firefox-41.0/libxul.so _is_ linked to system cairo.  I
> > assume this is because of libgdk-x11-2.0.so which pulls in
> > libpangocairo and therefore libcairo.
> 
> I noticed that too.
> 
> > And in about:config we're using
> > layers.offmainthread.composiiton.enabled true
> > 
> > Yes ?
> 
> Yes. No crashes so far with this setup.
> 
Thanks to you, and to Tim, for confirming this.  Much as I dislike
using mozilla's shipped libs when there is a newr version on the
system, I'm going to go with this.  Looking around, a post in
https://forums.gentoo.org/viewtopic-p-7801326.html suggested running
youtube, particularly in a background tab - that matches one of my
early crashes in 40.0 (i.e. left it playing, went to another tab to
check something).  I've now played a youtube film for 45 minutes,
about half of that time in a background tab, so this seems ok.

ĸen
-- 
Il Porcupino Nil Sodomy Est! (if you will excuse my latatian)
  aka "The hedgehog song"


More information about the blfs-dev mailing list