[blfs-dev] Plasma5 woes

Bruce Dubbs bruce.dubbs at gmail.com
Fri Sep 25 16:24:58 PDT 2015


I've built plasma-5.4.1, but I can't get it to start.  krunner crashes.

I built kf5 and plasma in debug mode and ran gdb from the kde crash 
handler.

#5  <signal handler called>
#6  0x00007fc544eb9de0 in QQmlComponent::status() const ()
    from /opt/qt5/lib/libQt5Qml.so.5
#7  0x00007fc545a75c20 in KDeclarative::QmlObject::completeInitialization (
     this=0x14da4e0, initialProperties=...)
     at 
/tmp/kf5/kdeclarative/kdeclarative-5.14.0/src/kdeclarative/qmlobject.cpp:312
#8  0x000000000040f35a in View::View (this=0x7ffe8a0e72e0)
     at 
/tmp/plasma5/plasma-workspace/plasma-workspace-5.4.1/krunner/view.cpp:94
#9  0x000000000040ddb1 in main (argc=1, argv=0x7ffe8a0e75f8)
     at 
/tmp/plasma5/plasma-workspace/plasma-workspace-5.4.1/krunner/main.cpp:75
(gdb)

I built kf5 and plasma in debug mode and

I searched for similar bugs and found:

https://bugs.kde.org/show_bug.cgi?id=347387
https://bugs.kde.org/show_bug.cgi?id=344550
https://bugs.kde.org/show_bug.cgi?id=343982

I added some things to 343982.

One of the bugs referred to

https://bugreports.qt.io/browse/QTBUG-42985

so it may be a Qt issue.

The issue now is how to handle this for blfs-7.8.  Do we leave it as 
"not ready for blfs" and go on to other things or try to resolve this?

By the way, there are other issues that can be worked around.  If kde4 
is present, then the PATH order is significant because there are 
executables with the same names in both kde4 and kf5/plasma5.  There 
also may be issues with initialization in that ~/.config has some files 
that are used by both versions.

I worked around both these above issues by creating a new user with a 
specific PATH that ignores kde4 and has the system create new 
configuration files.

BTW, kde4 works fine.  Running kdenlive and konsole using kf5 in xfce 
also work fine.

   -- Bruce


   -- Bruce


More information about the blfs-dev mailing list