[blfs-dev] Plasma5 woes

Ken Moffat zarniwhoop at ntlworld.com
Fri Sep 25 17:08:54 PDT 2015


On Fri, Sep 25, 2015 at 06:24:58PM -0500, Bruce Dubbs wrote:
> I've built plasma-5.4.1, but I can't get it to start.  krunner crashes.
> 
> I built kf5 and plasma in debug mode and ran gdb from the kde crash handler.
> 
> #5  <signal handler called>
> #6  0x00007fc544eb9de0 in QQmlComponent::status() const ()
>    from /opt/qt5/lib/libQt5Qml.so.5
> #7  0x00007fc545a75c20 in KDeclarative::QmlObject::completeInitialization (
>     this=0x14da4e0, initialProperties=...)
>     at
> /tmp/kf5/kdeclarative/kdeclarative-5.14.0/src/kdeclarative/qmlobject.cpp:312
> #8  0x000000000040f35a in View::View (this=0x7ffe8a0e72e0)
>     at
> /tmp/plasma5/plasma-workspace/plasma-workspace-5.4.1/krunner/view.cpp:94
> #9  0x000000000040ddb1 in main (argc=1, argv=0x7ffe8a0e75f8)
>     at
> /tmp/plasma5/plasma-workspace/plasma-workspace-5.4.1/krunner/main.cpp:75
> (gdb)
> 
> I built kf5 and plasma in debug mode and
> 
> I searched for similar bugs and found:
> 
> https://bugs.kde.org/show_bug.cgi?id=347387
> https://bugs.kde.org/show_bug.cgi?id=344550
> https://bugs.kde.org/show_bug.cgi?id=343982
> 
> I added some things to 343982.
> 
> One of the bugs referred to
> 
> https://bugreports.qt.io/browse/QTBUG-42985
> 
> so it may be a Qt issue.
> 
> The issue now is how to handle this for blfs-7.8.  Do we leave it as "not
> ready for blfs" and go on to other things or try to resolve this?
> 
I have no useful comment at this point, other than to note that
5.4.0 works fine for me, albeit rather slow to start.  That is for
7.8 builds without PAM, although I very much doubt that is relevant.

ĸen
-- 
Il Porcupino Nil Sodomy Est! (if you will excuse my latatian)
  aka "The hedgehog song"


More information about the blfs-dev mailing list