[blfs-dev] gnome tagging

Ken Moffat zarniwhoop at ntlworld.com
Sun Sep 27 16:47:13 PDT 2015


On Sun, Sep 27, 2015 at 03:59:48PM -0500, Bruce Dubbs wrote:
> Ken Moffat wrote:
> >On Sun, Sep 27, 2015 at 02:40:34PM -0500, Bruce Dubbs wrote:
> 
> >>gnome-terminal: From an xfce desktop, I get
> >>
> >>Error constructing proxy for
> >>org.gnome.Terminal:/org/gnome/Terminal/Factory0:
> >>Error calling StartServiceByName for org.gnome.Terminal:
> >>GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited:
> >>Process org.gnome.Terminal exited with status 8
> 
> >This reply is being typed in gnome-terminal :)  I opened it from the
> >menu (in an xfce desktop).  No issues here.
> 
> I'll try to see what the problem is.  Do you get any output if you just type
> gnome-terminal from another terminal's command line?
> 
No, all that happens is that the gnome terminal opens.

> I do note that in the System menu, I have:
> 
> Konsole (from kde4)
> Konsole (from kf5)
> LxTerminal
> Terminal
> XFCE Terminal
> 
> I then went into gnome-terminal.desktop and manually changed to:
> 
> Name=Gnome Terminal
> 
> We probably ought to do that in the book.

If we were to do that, we would have to change other things - gnome
likes to hide program names.  In my menus I can see the following,
and perhaps I have overlooked others :

Accessories
 Archive Manager       file-roller
 Calculator            gnome-calculator
 Character Map         gucharmap
 Files                 nautilus
 Network Tools         gnome-nettool
 Passwords and Keys    seahorse
 Screenshot            gnome-screenshot

Graphics
 Document Viewer       evince
 Image Viewer          eog

Internet
 Web                   epiphany

System
 Disk Usage Analyzer   baobab
 Network Tools         gnome-nettool (bis)
 System Monitor        gnome-system-monitor

> 
> When I try the gnome terminal from the xfce system menu, I get nothing.  I
> can't find any messages about it either.
> 

Have you tried strace ?
> If I run, gnome-terminal --help, that works, so there is probably some
> configuration issue on my end.
> 
> >>========
> >>network-manager-applet: comes up but doesn't do anything.  I've been testing
> >>wicd and I may not have network manager set up properly.
> >>
> >I built it, but AFAICS there is no program, only an xdg autostart
> >file.
> 
> It should install nm-connection-editor.  That's what I tested.
> 

My mistake, I overlooked that.  I can attempt to add an ethernet
connection, but all the field descriptions for setting it up are
greyed out as if it did not get added.

ĸen
-- 
Il Porcupino Nil Sodomy Est! (if you will excuse my latatian)
  aka "The hedgehog song"


More information about the blfs-dev mailing list