libavifile error

dTd dandanielle at cyberzone.net
Wed Apr 11 17:03:22 PDT 2001


On Thu, 12 Apr 2001 22:31:14 +0200
"Jeroen Coumans" <jeroencoumans at hotmail.com> wrote:

> > /bin/sh ../libtool --silent --mode=link c++  -I../include
> > -I/usr/X11R6/include -I/usr/local/qt/include
> > -I/packages/SDL-1.2.0/include -I/packages/SDL-1.2.0/include/SDL
> > -D_REENTRANT    
-DSHARE_PATH=\"/packages/avifile-0.53.5/share/avifile\"
> > -DWIN32_PATH=\"/usr/lib/win32\" -march=i586 -lpthread -ldl
> > -L/usr/X11R6/lib -lX11 -lXext -L/usr/local/qt/lib  -lqt
> > -L/packages/SDL-1.2.0/lib -Wl,-rpath,/packages/SDL-1.2.0/lib -lSDL
> > -lpthread -o aviplay  main.o renderer.o mywidget_if.o MyConfig.o
> > MyConfigImpl.o mywidget.o decoder_config.o      mmx.o
> > ../lib/libaviplay.la -lXxf86vm -lXxf86dga  -lpthread -ldl
> > ../lib/.libs/libaviplay.so: undefined reference to `__strcpy_small'
> > collect2: ld returned 1 exit status
> > make[1]: *** [aviplay] Error 1
> > make[1]: Leaving directory
> > `/usr/local/tmp/downloads/avifile-0.53.5/player'
> > make: *** [all-recursive] Error 1
> 
> The homepage (http://divx.euro.nu) mentions that if you get those
errors,
> you should try to compile without
> --enable-release, and to remove all optimization flags from CFLAGS.
> Hope this helps,

I know you need to remove the cflags optimizations as you'll get an
error everytime, at least I did. Also I believe you need the codecs
installed in /usr/lib/win32 before you configure.

-- 
dTd
Daniel T. Drea
dandanielle at cyberzone.net
http://users.cyberzone.net/dandanielle
Linux "tastes great, less filling"

-- 
Unsubscribe: send email to lfs-apps-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the blfs-support mailing list