Gnome And Berkeley DB... The nightmare continues!

Vodden, Richard richard.vodden at ic.ac.uk
Tue Jan 2 08:55:05 PST 2001


Oddly, when I run nm on /bin/libdb.so I don't see dbopen in there, which may
well be the source of the problem. I can't however, see a good reason for it
not being in there. Does anyone know anything about the actual DB interface,
and whether or not the gnome ./configure is looking for it correctly?
Failing that, has anyone actually got gnome to compile on an LFS system,
using gnome-libs 1.2.8 and DB 3.1.17 ? (or even 2.7.7).

Any help would be great... It's the first proper brick wall I've hit since
converting all my PC's to LFS.

Cheers

Rich

-----Original Message-----
From: Jarrett Carver [mailto:solarboyz1 at hotmail.com]
Sent: 02 January 2001 13:35
To: richard.vodden at ic.ac.uk
Subject: Re: Gnome And Berkeley DB... The nightmare continues!


Sorry to say I never got it installed. As it was a last minute project 
before I left a contract, I had limited time to spend trying. I did get past

the database errors, by adding the path to the DB library and include files 
to my $LD_LIBRARY_PATH environment variable. (you could also try using the 
-I and -L option during make)

I then ran into a plethora of other errors. Mostly dealing with graphics 
packages that Solaris 7 did'nt have, that needed to be installed in a 
specific order. Although it may be easier on Linux, since these may be 
common linux libraries.

Currently I have Gnome on my Linux, but I am running Suse, and the package 
is easily installed via YAST.

Hope this helps.


----Original Message Follows----
From: "Vodden, Richard" <richard.vodden at ic.ac.uk>
To: "'solarboyz1 at hotmail.com'" <solarboyz1 at hotmail.com>
Subject: Gnome And Berkeley DB... The nightmare continues!
Date: Mon, 1 Jan 2001 20:46:54 -0000

Hi!

I am trying to compile Gnome 1.2.8 on a linux box, and came across the exact
same error you reported on Sun Managers, i.e. dbopen not found in -ldb or
-ldb1. I have installed Berkeley DB 2.7.7 but to no avail, the error message
is still present. Did your build/install go smoothly after the Berkeley
install?

Thanks for your help

Rich

Newbe Linux Hacker

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com

-- 
Unsubscribe: send email to lfs-apps-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the blfs-support mailing list