no init found

Gerard Beekmans gerard at linuxfromscratch.org
Tue Jan 16 14:59:20 PST 2001


On January 16, 2001 05:18 pm, Pascal Adami wrote:
> Well, take a look at the subject...that's what my kernel says when I
> rebooted into LFS for the first time. I checked if init is here, and yes it
> is under /sbin. I tried to execute it with init 1 -6 a few times but
> nothing happens, it just goes back to shell after some seconds. The inittab
> is also correct. I also tried to recompile my kernel and the sysvinit
> package once more but no luck. I don't know what's wrong since some other
> older LFS systems I built had no problem with that.

Does the kernel mount the proper partition as root? If your LFS' root 
partition is, say hda5 but kernel mounts hda<something else>....

so step one, ensure that lilo.conf has the proper root file system.

You can also tell the kernel about it at the LILO prompt via:

LILO: lfskernel root=/dev/hda<something>

altenatively you can pass init=/path/to/a/program

like /sbin/init or /bin/bash

-- 
Gerard Beekmans
www.linuxfromscratch.org

-*- If Linux doesn't have the solution, you have the wrong problem -*-

-- 
Unsubscribe: send email to lfs-apps-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the blfs-support mailing list