Fwd: Re: gnome-libs and db solution

Gerard Beekmans gerard at linuxfromscratch.org
Mon Jan 22 11:35:26 PST 2001


I don't know if this is still an issue with gnome-libs but I received this 
message a day or two ago:

----------  Forwarded Message  ----------
Subject: gnome-libs and db solution
Date: Sat, 20 Jan 2001 16:33:15 -0500
From: Matt Powell <mpowell at resnet.gatech.edu>
To: Gerard Beekmans <gerard at linuxfromscratch.org>

I'm not a subscriber to any of the LFS mailing lists but I have used
them to solve some of my problems. Anyway, I found a solution to one of
the problems that I and some of the lfsapps list subscribers have had. I
found the attached patch in a bug report for gnome-libs. I would
appreciate it if you would forward this to the lfsapps list to help
others.

One needs to do the following to get gnome-libs to work:
patch -p0 -i ../gnome-libs.patch
sh macros/autogen.sh
.../configure --prefix=/usr
make
make install

Matt Powell

-------------------------------------------------------
-------------- next part --------------
--- configure.in.orig   Tue Oct 24 03:15:03 2000
+++ configure.in        Tue Nov 14 12:07:58 2000
@@ -302,14 +302,18 @@
 AC_CHECK_FUNC(dbopen, [],
 if test "$prefer_db1" = "yes"; then
  AC_CHECK_LIB(db1, dbopen, DB_LIB="-ldb1",
-  AC_CHECK_LIB(db, dbopen, DB_LIB="-ldb",
-   AC_MSG_ERROR([Your db library is missing db 1.85 compatibility mode])
+  AC_CHECK_LIB(db, __db185_open, DB_LIB="-ldb",
+   AC_CHECK_LIB(db, dbopen, DB_LIB="-ldb",
+    AC_MSG_ERROR([Your db library is missing db 1.85 compatibility mode])
+   )
   )
  )
 else
  AC_CHECK_LIB(db, dbopen, DB_LIB="-ldb",
   AC_CHECK_LIB(db1, dbopen, DB_LIB="-ldb1",
-   AC_MSG_ERROR([Your db library is missing db 1.85 compatibility mode])
+   AC_CHECK_LIB(db, __db185_open, DB_LIB="-ldb",
+    AC_MSG_ERROR([Your db library is missing db 1.85 compatibility mode])
+   )
   )
  )
 fi


More information about the blfs-support mailing list