Grub...what did it do to my kernel? =\

Dan dan at headzofstate.com
Sat Aug 3 03:14:01 PDT 2002


So, after hearing so much great stuff about Grub, I went and downloaded
the newest version from the GNU website, and compiled it all up...loaded
it into the boot sector of my 1st hard drive, like LILO was, and after
issuing the following commands at the boot prompt:

root (hd0,4)
kernel /boot/kernel-2.4.18 ro root=/dev/hda5
boot

I got the usual "Uncompressing the kernel..." etc., until the following
lines:

Dentry-cache hash table entries: 65536 (order: 7, 524288 bytes)
Inode-cache hash table entries: 32768 (order:6, 262144 bytes)
Mount-cache hash table entries: 8192 (order: 4, 65536 bytes)
Kernel panic: can't allocate root vfsmount
In idle task - not syncing

Ack!  So, figuring it was something to do with my Grub setup, I booted
my system from my trusty boot cd-r, and after chroot'ing into my LFS
installation, re-installed LILO with '/sbin/lilo -v', which proceeded
with no errors...I then rebooted my system, booted Linux via LILO,
and...the same error popped up.  Now nothing seems to be able to boot my
Linux kernel =(  I even tried putting a fresh copy of the
/usr/src/linux/arch/i386/boot/bzImage file into /boot/kernel-2.4.18,
with no avail.  Now I can't access my nice LFS system, and am doomed to
using Windows for the time being =(  (At least Windows XP boots nicely
from LILO and Grub alike... =P)  Anyone have *any* idea what could cause
this sudden kernel panic?  Thanks in advance for any ideas you might
have... =)

~D.A. Stone
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list