X11 configuration

adam bozanich adambozanich at sbcglobal.net
Tue Aug 6 17:59:35 PDT 2002


Richard Jones wrote:

>> Was it adam bozanich who wrote on Wednesday 31 July 2002 01:18:
>> > Declan Moriarty wrote:
>> > > Was it Didier Richard who wrote on Tuesday 30 July 2002 09:10:
>> > >> adam bozanich wrote:
>> > >> > Jeffrey B. Ferland wrote:
>> > >> >>>(EE) GARTInit: Unable to open /dev/agpgart (No such file or
>> > >> >>> directory)
>> > >> >>
>> > >> >>I don't think the /dev/agpgart file exists. Check the
>> > >> >>/usr/src/linux/Documentation/Devices.txt file for
>> details on how
>> > >> >>to creat that file. If that is not the case, check your kernel
>> > >> >>config to see if you've compiled support. We'll move on from
>> > >> >>there
>> > >
>> > > Here's what mine looks like
>> > >
>> > >
>> > > [root at genius /dev]# ls -l agp*
>> > > crw-rw-r--    1 root     root      10, 175 Apr 14  2001 agpgart
>> >
>> > thanks for the help, but I still can't get to work
>> correctly.  I have
>> > compiled agp into my kernel, and i have the correct chipset
>> compiled
>> > in too, but I still don't have /dev/agpgart.  I looked at
>> > /usr/src/linux/Documentation/Devices.txt, but i can't
>> figure out what
>> > that is trying to tell me.  I have tried to copy /dev/agpgart over
>> > from my redhat system, but it won't let me copy the file.  any
>> > suggestions?
>> 
>> The idea was that you make it, using mknod
>> 
>> mknod   /dev/agpgart    c,    10,    175   and then sort out
>> your permissions
>> with chmod.
>> 
>> --
>> Regards,
>> 
>> 
>> Declan Moriarty
> 
> I had this same problem when I set up X. The mknod command will create
> the /dev/agpgart file you need and it should work assuming everything
> else is set up properly. (Do you need commas in the command? Check the
> man page.) The weird Devices.txt file contains lists of what numbers to
> use when creating device files (and other info as well). For example if
> you look in section 10, at device number 175 it should say /dev/agpgart.
> You use those numbers in the mknod command to create the device files.
> The "c" in the command above tells mknod that the device is a character
> devise.
> 
> I'm not sure yet how one is supposed to know what /dev files to make for
> which programs/hardware; I just started working from the error message
> that X gave me. I assume it all depends on what hardware you are using.
> My board has the intel 810 graphics, and if I'm not mistaken, I think I
> saw something about 810 somewhere in your error log as well. If ones
> hardware didn't use the /dev/agpgart node then X should be able to run
> without it.
> 
> One other thing to mention. After I got X going I had trouble starting
> xterm sessions. It turns out that Xterm wasn't able to find any pty's
> (pseudo terminals) to use for the sessions (each xterm window requires a
> pty, like Alt+F#). This same problem popped up when I tried to use SSH.
> I tried to set up the pty devices manually, but couldn't get it to work.
> Setting up devpts eventually took care of all those problems. It was
> really easy, but I didn't do it when I originally built my LFS system.
> There are directions in the book.
> 
> Hope that helps.
> 
> -Richard
> 


Thank you very much.  That helped a lot.  I can now get to the point where 
the test screen comes up correctly (with the X for the mouse and the 
lattice background), however the screen gets stuck there.  The only way to 
get out is ctrl+alt+F2, but then when i attempt to reboot my system, i get 
back to the test screen and it freezes there.  I don't want to have to keep 
turning off my system with out properly shutting down, what ells could i 
do?
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list