XF86Config.newbie

adam bozanich adambozanich at sbcglobal.net
Fri Aug 9 00:29:04 PDT 2002


Hi everybody. I am attempting to set up xfree86 on my lfs and am having some 
problems. When I try to test the XF86Config.new file, everything comes up 
o.k., but then the screen never changes and i have to do ctrl+alt+del to 
get out. Here's the lines from the log file which have warnings:

(WW) Open APM failed (/dev/apm_bios) (No such file or directory)
(WW) System lacks support for changing MTRRs
(WW) I810(0): xf86AllocateGARTMemory: allocation of 1024 pages failed
                                  (Cannot allocate memory)

Does anybody have any suggestions for me?

I enabled advanced power management as well as the bios option in 
menuconfig, but i still get this.  I have also created /dev/apm_bios and 
made it executable.

Also, (this is wierd, because it used to not happen) it seems like I don't 
have the mouse settings entered correctly, because the cursor does not act 
right.  It goes to the top right when i move it and sporatically moves a 
little.  I think it's a problem in the script, but i can't pinpoint it.  
Can anyone help?  here's the mouse part of my XF86Config.new file: (i have 
a compaq presario, /dev/psaux, and i guess PS/2? with gpm, i used imps2 but 
xf86 wouldn't recognise that setting)

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "PS/2"
        Option      "Device" "/dev/mouse"
EndSection

I have tried to use imps2 instead of PS/2 and /dev/psaux instead of 
/dev/mouse, but neither work.

I won't lie- i'm a linux newbie, but I would like to fix this bug and go on 
with installing X.  I enjoy working with the LFS books a lot, but am 
becomming frusterated with this problem.  Any help would be great.  Thank 
you.

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list