/etc/ppp/ip-up not working

Mark Ellis mark.uzumati at virgin.net
Fri Aug 9 02:37:16 PDT 2002


On 2002.08.09 11:06 Daniel Brewer wrote:
> I think I might of confused people by not explaining my problem 
> properly.  What I meant to say is that I have a dial-up connection 
> working perfectly well using the ppp HOWTO scripts.
> The problem is that is does not execute the /etc/ppp/ip-up script.  I 
> have changed the mode so it is executable and it is owned by root.  
> The script works fine if you run it manually after a connection has 
> been made but it does not automatically execute it went the link is 
> established.
> This is what it looks like:
> 
> #!/bin/sh -vx
> /usr/local/games/fortune
> exit 0
> 
> Any ideas?
> 

This won't be much help, but i occasionally have this problem too,
though not as often now. I put it down to a bizarre bug in pppd, never
could find any consistency in when it failed to run the script. If i
remember correctly you have an on-demand setup ? I do to, and the best
i could figure out was that if i just ping to bring up the line the
script commonly failed to run, whereas if i for instance tried a
browser it usually worked. Made no sense at all, though i don't
remember any problems for a while.

What kernel and pppd version are you using ?

Mark
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list