Please guide me in alsa installation?

Mark Ellis mark.uzumati at virgin.net
Fri Aug 9 07:28:17 PDT 2002


On 2002.08.09 14:00 Seng Huat Yeoh wrote:
> Hi,
> 
> I went through alsa's installation in the BLFS book.   However,  XMMS 
> still unable to detect my soundcard.   I'm using an MSI KT333-Ultra 
> mobo with VT8233a southbridge.
> 

Unable to detect ? Whats the message ?

> 
> 1) Before installation,  I've checked that my kernel has,
> Sound:
> <M> Sound card support
> ...
> ...
> <M> OSS sound modules
> ...

You don't need the second, probably doesnt matter but it might 
complicate
the issue.

> 
> 
> 2) I proceed to install the driver with:
> ./configure \
>    --with-moddir=/lib/modules/2.4.19/kernel/drivers/sound/ \
> 	--with-kernel=/usr/src/linux-2.4.19 \
> 	--with-sequencer=yes --with-oss=yes \
> 	--with-cards=via8233 &&

Leave out the --with-moddir, you shouldn't need it and i'm not sure its
correct.

> make &&
> make install
> 
> 3) Modified /etc/modules.conf and substituted <soundcard> with 
> via8233.   I skipped the /etc/rc.d/init.d/alsa and 
> /etc/sysconfig/alsa scripts altogether and ignored creating symlinks 
> in rc.#.d directories.
> 
> 4) Ran ./snddevices
> 

Static /dev or are you using devfs ?

> 5) Installing alsa-lib and alsa-utils.   Did not install alsa-oss-lib 
> and also-tools because I couldn't run ./configure in both of their 
> source directories.
> 

S'okay.

> 6) Configure alsa by making symlinks 
> /dev/sndstat->/proc/asound/sndstat.   Finally chmod-ed device 
> permissions.
> 
> 
> I basically followed the alsa installation in blfs.   Am I missing 
> something?   If there's anything helpful I've yet to provide,  let me 
> know.   I know I'm missing alot of things.
> 

Alsa setup is always funky.

Mark
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list