Mozilla 1.0 & libstdc++2.90.6 & 8, compile errors.

Andy Bennett andyjpb at ashurst.eu.org
Mon Aug 12 15:12:53 PDT 2002


Hi,

I am not sure whether this belongs in lfs-support or blfs-support, but I
think here is most appropriate because it is a mozilla dependency.

I have been trying to install mozilla 1.0, from source, on my LFS-3.3
system. One of the dependencies that I need to install is libstdc++2.90. -
The mozilla make bombs on string.h IIRC.

Anyway, I have libstdc++2.90.8 and libstdc++2.90.6 from ftp.gnu.org.
I am running GCC 2.95.3.

When attempting to compile either of these packages, they both bomb out
during the make process with the following;


Making all in src
make[2]: Entering directory `/usr/src/bld-libstdc++/src'
/bin/sh ../libtool --mode=compile
c++ -DHAVE_CONFIG_H -I. -I../../libstdc++-2.90.6/src -I.. -nostdinc++ -I../.
./libstdc++-2.90.6 -I../../libstdc++-2.90.6/stl -I../../libstdc++-2.90.6/lib
io     -g -D_GNU_SOURCE -fno-implicit-templates  -c
../../libstdc++-2.90.6/src/basic_file.cc
rm -f .libs/basic_file.lo
c++ -DHAVE_CONFIG_H -I. -I../../libstdc++-2.90.6/src -I.. -nostdinc++ -I../.
./libstdc++-2.90.6 -I../../libstdc++-2.90.6/stl -I../../libstdc++-2.90.6/lib
io -g -D_GNU_SOURCE -fno-implicit-templates -c  -fPIC -DPIC
../../libstdc++-2.90.6/src/basic_file.cc -o .libs/basic_file.lo
../../libstdc++-2.90.6/src/basic_file.cc: In method `struct __c_streampos
__basic_file::seekpos(_G_fpos64_t, _Ios_Openmode = operator |((enum
_Ios_Openmode)1, (enum _Ios_Openmode)2))':
../../libstdc++-2.90.6/src/basic_file.cc:202: `struct __c_streampos' used
where a `long long int' was expected
make[2]: *** [basic_file.lo] Error 1
make[2]: Leaving directory `/usr/src/bld-libstdc++/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/bld-libstdc++'
make: *** [all-recursive-am] Error 2


I have tried different configure options and have also tried building it as
part of GCC from scratch, but the same error always occurs.
I have CFLAGS=-O3 -march=i686 and CXXFLAGS=-O3 -march=i686 but have tried
compiling with and without these set.
The machine is an Intel Pentium PRO with 80MB RAM.

I have also installed the zip and libIDL dependencies for moxilla
successfully.


Can anybody shed any light on my problem?

I appologise if this has been asked before - I had a quick scan of the
lfs-support and blfs-support archive but the libstdc++ problems in the past
did not seem to fail in this way.


Thanks for you time.



Regards,
@ndy

--
andyjpb at ashurst.eu.org


-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list