Mozilla 1.0 & libstdc++2.90.6 & 8, compile errors.

Simon Geard delgarde at ihug.co.nz
Thu Aug 15 03:25:40 PDT 2002


Andy Bennett wrote:

> Hi,
> 
> >> I have been trying to install mozilla 1.0, from source, on my
> >> LFS-3.3 system. One of the dependencies that I need to install is
> >> libstdc++2.90. - The mozilla make bombs on string.h IIRC.
> 
> > Why exactly do you need that package? Mozilla should compile quite
> > happily with the libstdc++ version installed with GCC during the LFS
> > build. The usual reason to stuff around with older versions is when
> > dealing with binaries compiled against with older GCC versions.
> 
> I think that libstdc++2.90 is newer that the library supplied with gcc
> 2.95.3
> The one supplied with gcc 2.95.3 is a version 2 one. 2.90 unpacks as
> libstdc++-v3.

I don't know about that, but the file I have is
"libstdc++-3-libc6.2-2-2.10.0.so" - that came from gcc2.95.3. The
equivalent file for gcc3.1 is "libstdc++.so.4.0.0".

In any case, Mozilla should not need any unusual versions of the library
- I've successfully compiled 1.0 against both 2.95 and 3.1 without any
problems.

Simon.
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list