Mouse and keyboard locking up

Chris Schwemmer chris.schwemmer at t-online.de
Tue Aug 20 07:24:38 PDT 2002


So, now I tried recompiling the kernel without APM (some messages in the 
kernel archives pointed in that direction), tried different mice, tried 
it as root and as mortal, switched device permissions back and forth (I 
even tried chmod a-w psaux), no difference. I wanted to try kernel 
2.4.13, because that's what I had before LFS on this machine, but just 
after starting init it oopses with a NULL pointer reference and then 
panics because it tries to kill init...
I also tried a working gpm binary from another LFS machine I have, no 
difference.
The only difference I see between my LFS and KNOPPIX here that could 
have an impact is gcc. Could it be a problem with gcc 3.2 and the kernel?
I also checked the kernel mailinglist, there were some similar problems, 
although not exactly what I have, but these were either with older 
kernels or resolved in a way that didn't make a difference here.
On the gpm mailinglist one post says that it's a known problem with the 
kernel keyboard driver and to switch to a newer kernel (it was an older 
post), but I'm running 2.4.19...
This isn't funny anymore, I need my system for work asap... :(

Chris

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list