Problem's compiling sp-1.3.4

Roy Ens royens2 at cox.net
Fri Aug 23 00:34:16 PDT 2002


I'm going through the Gnome-1.4 hint right now and I'm trying to install
sp-1.3.4 which is not working. 
The hint says to use sed to change a few things in the Makefile such as
installation location from /opt/local to /usr/local and also changing
CXX and CFLAGS. I've tried changing all these with and without sed and I
consistently get the same error. I've looked at some of the source code
and can't find the reason for the error. I'm using gcc-3.1 and have a
CVS version of LFS from like 3 weeks ago. Following is the error message
that I get.

./include/RangeMap.h:57:warning: implicit typename is deprecated,
please see the documentation for details
CmdLineApp.cxx: In member function `int CmdLineApp::run(int, char**)':
CmdLineApp.cxx:217: parse error before `)' token
make[2]: *** [CmdLineApp.o] Error 1
make[2]: Leaving directory `/usr/src/sp-1.3.4/lib'
make[1]: *** [lib] Error 2
make[1]: Leaving directory `/usr/src/sp-1.3.4'
make: *** [all] Error 2

Any help would be appreciated.

---
Roy Ens
**********
royens2 at cox.net
ens at cs.ttu.edu
roy.ens at ttu.edu
*********

Why wake up in the morning if 
you can't program all day?

---

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list