alsamixer won't start?

Jerry Hoover jbhoo at charter.net
Fri Aug 23 21:59:18 PDT 2002


James Drabb wrote:
>>-----Original Message-----
>>From: Jerry Hoover [mailto:jbhoo at charter.net] 
>>Sent: Friday, August 23, 2002 7:49 PM
>>To: blfs-support at linuxfromscratch.org
>>Subject: alsamixer won't start?
>>
>>
>>I have installed the alsa driver lib & utils packages 
>>-0.9.0rc3 with the
>>latest blfs book, and useing soundblaster live card.
>>no errors when installing packages and choose to have the kernel load
>>the modules and not use the scripts.
>>when I try to run the mixer I get
>>
>>alsamixer:function snd_ctl_open failed for default: No such file or
>>directory
>>
>>I have installed xmms and it works but of course no sound with out 
>>unmuting a mixer.
>>
>>I tried installing aumix-2.7 and get a configure error
>>checking/console.h....presence no
>>checking/console.h....no
>>./configure line 3746 syntax error unexspected token (s'
>>
>>
>>
>>I have tried runing ./snddevices that diden't help
>>any help would be appreciated
>>
>>
> 
> 
> It looks like alsamixer is looking for a device file that is not
> there or there is no write permissions to the device.  What do you
> get from: ls -l /dev/sound /dev/snd
> Also, are your alsa modules loaded before you runl alsamixer?  Do
> lsmod to make sure they are and if not manually load the modules.
> If your /etc/modules.conf file is not setup correctly, then the
> kernel module autoloader will not work.
> 
> Jim Drabb
> 

i did ls -l /dev/sound No such file or directory
bouble checked modules.conf looks ok?

  modules.conf file
alias eth0 8139too
alias char-major-116 snd
options snd snd_major=116 snd_cards_limit=1
alias snd-card-0 snd-card-emu10k1
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-3 snd-pcm-oss
post-install snd-card-emu10k1 /usr/sbin/alsactl restore

But i run lsmod and emu10k1 isent there.
cd to lib/modules/kernel/drivers/sound and all the emu10k1.o files are 
there. there snd-emu10k1****.o would that make difference in the 
modules.conf file? the snd-
tried insmod snd-emu10k1.o and got a bunch of unresolved symbols


-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list