alsamixer won't start?

Jerry Hoover jbhoo at charter.net
Sat Aug 24 21:26:02 PDT 2002


Horacio Ferrero wrote:
> On Sat, 2002-08-24 at 01:49, Jerry Hoover wrote:
>     I have installed the alsa driver lib & utils packages -0.9.0rc3 with the
>     latest blfs book, and useing soundblaster live card.
>     no errors when installing packages and choose to have the kernel load
>     the modules and not use the scripts.
>     when I try to run the mixer I get
>     
>     alsamixer:function snd_ctl_open failed for default: No such file or
>     directory
>     
>     I have installed xmms and it works but of course no sound with out 
>     unmuting a mixer.
>     
>     I tried installing aumix-2.7 and get a configure error
>     checking/console.h....presence no
>     checking/console.h....no
>     ./configure line 3746 syntax error unexspected token (s'
> 
> Don't worry, you're not alone. We are two having the same problem...
> I'd recompiled the kernel to get a clean situation but the problem is
> already in!
> 
> 
> 
I fixed it by adding <snd->  before the name of the driver and running 
modprobe.
The blfs book dozen't have it this way for the newer alsa 9.0rc3 drivers
compare mine to the book and youl see the difference! the newer driver 
modules start with snd-foo

 >
 > modules.conf
alias eth0 8139too
alias char-major-116 snd
options snd snd_major=116 snd_cards_limit=1
alias snd-card-0 snd-card-snd-emu10k1
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-3 snd-pcm-oss
post-install snd-card-snd-emu10k1 /usr/sbin/alsactl restore




-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list