problem with msdos fat and VFAT modules

Scot Mc Pherson scot at linuxfromscratch.org
Wed Aug 28 14:59:06 PDT 2002


On Wed, 28 Aug 2002 16:23:08 -0400, Steven Stimpson wrote:

> I have the strangest problem with these two modules. when i compile them
> as modules all of my files on my cdrom are truncated like micro~1
> 
> i tried compiling them directly into the kernel and it worked fine for a
> while then it started doing it again. so i made them as modules. now
> they are working again but i have to manually modprobe them to get them
> to load. can any one of you get me out of this sticky mess? thanks
> Steven
 
Mkae sure you are actually loading the vfat modules as well, just
comi\piling the vfat module, but lodiong the msdos module will not enable
long files names.

I compile filesystem support right in the kernel (I compile everything
right in the kernel actally, and only create modules for thing that I
consider rare usage.)

It should fix the problem, though I think you said you enabled it right
in the kernel too and caused the problem.

I have a bit of inspiration here at the moment...if you are allowing the
filesystems to be autodected on mount, then it might not be detected
rpoperly...this is very common....just ensure your mount uses -t vfat.

mount -t vfat /dev/hda5 /mnt/dos

umdos is another good extenstion to enable as it allows you to use unix
permissions and attribs ont he dos/vfat filessytems.

Scot Mc Pherson
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list