Perl problem - perl complains it cannot find ioctl.ph

Alan Womack arwbackup at worldnet.att.net
Fri Aug 30 04:47:34 PDT 2002


CROSS posted:

blfs-support
misterhouse-users


The problem is coming from an issue running h2ph..

I found the proper location resulting in the error in another Misterhouse Module

root at webby:bin# ./mh

Command: mh
Pgm  path   : .
Pgm  version: 2.69      Last updated: Mon Jul  1 15:20:50 2002
Perl version: 5.006001
OS   version: linux linux
Other       : user=root pid=16647 box= cpu=-

Reading parm files: ./mh.ini ./mh.private.ini /usr/local/Alan/mh.private.ini
Code Directories:
 - /usr/local/Alan
 - ./../code/common
trying 'sys/ttycom.ph'...
Device::Serial error: Can't locate sys/ttycom.ph in @INC (did you run h2ph?) (@INC contains: /usr/local/Alan ./../code/common ./../lib ./../lib/site . /usr/lib/perl5/5.6.1/i686-linux /usr/lib/perl5/5.6.1 /usr/lib/perl5/site_perl/5.6.1/i686-linux /usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl .) at ../lib/site/Device/SerialPort.pm line 32.

trying 'termios.ph'...
Device::Serial error: Can't locate termios.ph in @INC (did you run h2ph?) (@INC contains: /usr/local/Alan ./../code/common ./../lib ./../lib/site . /usr/lib/perl5/5.6.1/i686-linux /usr/lib/perl5/5.6.1 /usr/lib/perl5/site_perl/5.6.1/i686-linux /usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl .) at ../lib/site/Device/SerialPort.pm line 32.

trying 'sys/termios.ph'...
Device::Serial error: Can't locate sys/termios.ph in @INC (did you run h2ph?) (@INC contains: /usr/local/Alan ./../code/common ./../lib ./../lib/site . /usr/lib/perl5/5.6.1/i686-linux /usr/lib/perl5/5.6.1 /usr/lib/perl5/site_perl/5.6.1/i686-linux /usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl .) at ../lib/site/Device/SerialPort.pm line 32.

trying 'asm/termios.ph'...
Device::Serial error: Can't locate linux/stddef.ph in @INC (did you run h2ph?) (@INC contains: /usr/local/Alan ./../code/common ./../lib ./../lib/site . /usr/lib/perl5/5.6.1/i686-linux /usr/lib/perl5/5.6.1 /usr/lib/perl5/site_perl/5.6.1/i686-linux /usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl .) at /usr/lib/perl5/site_perl/5.6.1/i686-linux/linux/posix_types.ph line 5.
Compilation failed in require at /usr/lib/perl5/site_perl/5.6.1/i686-linux/asm/termbits.ph line 5.
Compilation failed in require at /usr/lib/perl5/site_perl/5.6.1/i686-linux/asm/termios.ph line 5.
Compilation failed in require at ../lib/site/Device/SerialPort.pm line 32.

Device::Serial could not find ioctl definitions!
Loading other modules
Starting setup
Creating socket and serial objects
 - creating http            on tcp  8080 buffered
 - creating server_telnet   on tcp  1234
 - creating server_mhsend   on tcp  8084 buffered
 - creating cm11            object on port /dev/ttyS0
disabling ioctl methods - constants not found
Process id 16647 written to ./../data/mh.pid
External command file (xcmd_file): ./../house_cmd.txt
HTML file     : ./../web/ia5

Warning:  password_file ./../data/.password not found.  Run mh/bin/set_password

Read in 8 items from ./../data/password_allow
Read in 1 commands from from ./../data/disabled_commands
Done with setup

08/30/02 04:11:32 AM Re-reading /usr/local/Alan/mh.private.ini and mh.ini
08/30/02 04:11:32 AM Translating items.mht -> /usr/local/Alan/items.mhp
08/30/02 04:11:32 AM Initialized read_table_A.pl

Unrecognized .mht entry: </XMP></BODY></HTML>
08/30/02 04:11:32 AM Reading 24 code files


when I run h2ph I get this, and then it hangs:


root at webby:perl5# h2ph
require '_h2ph_pre.ph';




-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list