kde3 login problems

Bill Maltby LFS Related lfsbill at wlmcs.com
Sat May 4 03:18:14 PDT 2002


On Sat, 4 May 2002, Meir Kriheli wrote:

> On Saturday 04 May 2002 12:26, Bill Maltby LFS Related wrote:
> > On Sat, 4 May 2002, Meir Kriheli wrote:
> > > ><snip>
> > > >
> > > >I have another question about the output of the mount command...I'm used
> > > > to see the root dir as /dev/hdX. But when I give the mount command on
> > > > this lfs system it gives me /dev/root as output, no info on the
> > > > partition..Is this normal?
> > >
> > > When I run mount on my system I get (for the root device):
> > >
> > > /dev/root on / type xfs (rw)
> > >
> > > It seems the same as yours output, can't tell you if it is normal.
> >
> > I also get this. I *think* it started with the 2.4.18 kernel? I'm
> > not sure. I don't like it. Maybe it's related to symlinking /etc/mtab
> > or building kernel in chroot or ???
> >
> > But, unfortunately, it is normal. Just like the old SCO Xenix stuff.
> > Can't tell diddly about the device.
> >
> > Bill Maltby
> > billm at wlmcs.com
> 
> I grepped the kernel source tree for /dev/root.
> 
> I found in Documentation/devices.txt /dev/root listed under the section 
> locally defined links. Those links are (qouting):
> 
> <qoute>
> The following links may be established locally to conform to the
> configuration of the system.  This is merely a tabulation of existing
> practice, and does not constitute a recommendation.  However, if they
> exist, they should have the following uses.
> 
> /dev/mouse      mouse port      symbolic        Current mouse device
> /dev/tape       tape device     symbolic        Current tape device
> /dev/cdrom      CD-ROM device   symbolic        Current CD-ROM device
> /dev/cdwriter   CD-writer       symbolic        Current CD-writer device
> /dev/scanner    scanner         symbolic        Current scanner device
> /dev/modem      modem port      symbolic        Current dialout device
> /dev/root       root device     symbolic        Current root filesystem
> /dev/swap       swap device     symbolic        Current swap device
> </qoute>
> 
> I've tried to create symbolic link /dev/root, and the run mount but the result 
> was the same.

Yeah, when I first saw it, I looked for a /dev/root. Nowhere to be found.
The only way I've found so far to tell what is really mounted as root is
cat /proc/cmdline. In there will be a root= from Lilo (if you do Lilo -
I don't know about grub). You can then translate the hexidecimal number
to major/minor device and do an ls on /dev piped to a grep to find out
what device is mounted as root. I can tell you it is *not* reliable
either.

Gee! That's nice - a whole lot simpler than the way we used to do it -
"mount".  :P

> 
> Maybe this is a 2.4.18 thing ?

Bill Maltby
billm at wlmcs.com

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list