Grub error

jazernorth jazernorth at gmail.com
Thu Sep 16 04:22:32 PDT 2004


Jeroen Coumans wrote:
> Hi guys,
> 
> At work I'm installing Linux but I can't seem to get the booting to work...
> 
> We have a 4-disk SATA configuration which is recognized and setup as such:
> 
> /dev/sda1 (hd2,0) -> /boot/ (ext3)
> /dev/sda2 (hd2,1) }
> /dev/sdb1 (hd3,0) } -> SW-raid5 = /dev/md0 = / (ext3)
> /dev/hde1 (hd0,0) }
> /dev/hdg1 (hd1,0) }
> 
> When I startup from a live CD, I can mount everything and it seems to 
> work. I setup grub as follows:
> root(hd2,0)
> setup (hd2)
> 
> Which gives no errors. However, if I reboot the system, GRUB halts at this:
> "GRUB Loading stage1.5.
> 
> GRUB loading, please wait...
> Error 17"
> 
> Which means: Cannot mount selected partition. This error is returned if 
> the partition requested exists, but the filesystem type cannot be 
> recognized by GRUB.
> 
> Well, GRUB shouldn't have a problem with ext3, should it? Especially 
> since it got as far as stage 1.5. I've also tried to setup (hd0), maybe 
> GRUB recognizes the drives differently then the BIOS, but it results in 
> the same error.
> 
> TIA,
> 
I get the same error on boot.

/dev/hda -> hd0 (not using for LFS, has rh9)
/dev/hdb -> hd1 (not using for LFS, has rh9)
/dev/sda -> hd3 (Swap is 0, ext3 is 1)

I did:
root (hd3,1)
setup (hd3,1)

When I make my SCSI boot, I get the Error 17 as stated above.  I know it 
works, cause I had it working until I goofed and deleted most of my 
drive.  Had to redo all of LFS, besides I was doing 5.0, so I upgraded 
to 5.1 since I had to redo it.

I think we probably have the same error.

Any help would be appreciated.

JN



More information about the blfs-support mailing list