Invalid pointer in XMMS

Giulio Daprelà daprela at gmail.com
Thu Aug 4 08:26:07 PDT 2005


On 8/4/05, Alexander E. Patrakov <patrakov at ums.usu.ru> wrote:
> >
> >>I have installed XMMS 1.2.10 and all his optional dependencies.
> >>When I run the program from Konsole I get this error:
> >>
> >>Gdk-WARNING **: locale not supported by Xlib, locale set to C
> >
> >
> >  normal, as Matt remarked.
> 
> No, please change LANG (and LC_ALL if it is [needlessly] set) to one of
> the values listed in the left column of
> /usr/X11R6/lib/X11/locale/locale.alias. Also please verify that the
> "locale charmap" prints the correct result.
> 

Ok, I'll try changing LANG as you suggest.


> >  I had something similar a few months back on ppc, caused by one of the
> > plugins, but I can't find any notes.  I tracked it down by building gdb,
> > starting XMMS from within gdb, then doing a backtrace (bt) after it
> > crashed.  The trace showed it was in some sort of startup code and
> > calling one of the plugins.  I removed the plugin (all I remember was
> > that it was for something that I didn't think was very important) and it
> > worked fine.
> 
> Is aRts output plugin installed?
> 

I have aRtsd installed and working in KDE.


I also noticed that the XMMS site claim also the following dependency:

OpenGL Visual plugin: Mesa 3.0 or better

Maybe you should add this to the optional dependencies in the book.


Giulio
--------------------------
Linux user #356310
LFS user #11031



More information about the blfs-support mailing list