grub errors and read-only

Ken Moffat ken at kenmoffat.uklinux.net
Fri Aug 5 05:42:39 PDT 2005


On Fri, 5 Aug 2005, Donal Farrell wrote:

> Hi there. I'm having serious problems since I put FC4 on my system which
> already has (B)LFS 6.0 and SuSE 9.1. I can't boot into SuSE or LFS at
> present. Actually, FC4 might not be the problem. I tried to put Sarge
> on /dev/hda which was a primary partition I made. I'm using the
> linuxformat dvd, so I had to disable my cdrom and enable the dvd-rw in
> the bios. This is all very well until the debian base package tries to
> install where it looks for the cd drive. I tried to mount debian
> on /boot in /dev/hda2. Prior to this, suse was mounted on / on /dev/hda1
> and lfs on / on /dev/hda4 with a swap on /dev/hda3. After I aborted the
> debian install to try make iso cds instead of the dvd, I got stuck when
> trying to boot into suse. using the suse rescue disk, i did a
> fsck.reiserfs which repaired any errors on /dev/hda1. grub however
> failed to recover, pointing to a mount error on /dev/hda2 (????) I tried
> booting the installed system using the rescue cd (i.e. to boot suse on /
> on /dev/hda1) the result was my root directory mounted read-only and a
> fsck.reiserfs showing error 6 for /dev/hda2
>

 Hi Donal,

 I'm not a grub user, but let's see if I've understood what you are
telling us:

(i.) You used to have a shared /boot partition on /dev/hda2, but you
overwrote it with a fedora install to try to get things working

(ii.) The fedora system works, and can mount the Suse and LFS systems.


> I installed FC4 to get a working system. Fine. FC4 is mounted on /
> on /dev/hda2 (ext3) I then mounted suse to mount (i.e.
> mount /dev/hda1 /mnt) I still have everything here, which is fine. Also,
> I can mount LFS (mount /dev/hda4 /mnt) and everything is fine here also.
> I tried to get a backup menu.lst from /var/log/messages and
> from /boot/grub/menu.lst~old ->nothing
> Also, and sorry about the message length, here is my /etc/fstab for SuSE
>
> /dev/hda2            /boot                reiserfs   acl,user_xattr
> 1 2
>
> This seems strange. The /boot mount point for debian still exists. Even
> though fdisk shows
> /dev/hda1              96       62523    31463302+  83  Linux (suse)
> /dev/hda2   *       62524       93731    15728832   83  Linux (fedora)
> /dev/hda3           93732       95812     1048824   82  Linux swap
> /dev/hda4           95813      127020    15728832   83  Linux (This is
> lfs)
>

(iii.) You only have primary partitions - even if there is free
unpartitioned space on the drive, you can't access it (a maximum of 4
primary partitions, none of them used to contain an extended partition).
Not even a shared /home - ouch, a very hair-shirt existence :)

> So what should I do now to get suse and lfs back running? Thanks in
> advance
>

 It seems to me that your missing /boot partition is going to prevent
Suse and LFS booting.  As I understand it, grub is now using fedora's
/boot *directory* to find the available kernels.  I think the following
should be close to getting you booted :

 first for Suse, then for LFS

(a.) mount the partition somewhere.

(a.) Put the required kernel(s) in fedora's /boot directory, where grub
can find them.  Make sure they have distinct names.  Edit the menu in
fedora so that the command lines ("boot arguments") match what you used
to use.

(b.) On the mounted partition, edit the etc/fstab file so that '/boot'
is commented out.

(c.) umount the partition.


 After this, try booting them.  Or even just do it for Suse the first
time, then try booting that.

 Once you get it working, you should consider backing up the important
data (I include the LFS system as data) and repartitioning.  The best
partitioning strategy depends in part on how many systems you want to
run.  I'd go for something like a boot partition (could be primary, for
old stick-in-the-muds like me) and an extended partition containing
swap, a number of root systems [ at least two for host and LFS,
becoming LFS and newer LFS ], /home, possibly others.


Ken
-- 
 das eine Mal als Tragödie, das andere Mal als Farce




More information about the blfs-support mailing list