shadow-4.0.9 errors persist

Harris Christian D SSgt 1 CS/SCBAM Christian.Harris at langley.af.mil
Fri Aug 5 07:14:12 PDT 2005


I'm am still getting the various 'unknown item' configuration errors

after re-installing shadow for PAM functionality. But I am still able

to login/su. I patched the shadow-4.0.9 source with 

shadow-4.0.9-LINUX_PAM-fixes-1.patch. But that did not solve the

problem. I even tried shadow-4.0.10 (with the corresponding patch)

with no success. It's still the same subset of variables from the 

/etc/login.defs file that everyone else experiences. I starting to think

that maybe I have a problem not related to the erroneous message

bug of shadow/PAM. Is there a way I can verify that the problem is

shadow/PAM bug, or if I need to look at my system for errors?

 

Also, I have found two different 3 deferent versions of the patch
itself. 

I found 2 different shadow-4.0.9-Linux_PAM_fixes-1.patch's. One

has an entry in the header that say 'Initial Package Version: 4.0.9'

and the other has the entry 'Initial Package Version: 4.0.10'. And 

they both are different. There's also the less relevant

shadow-4.0.10-Linux_PAM_fixes-2.patch, which I applied to 4.0.10, 

with no success. I'd hate to stray so far from 4.0.9 from the blfs 

pre6.1 book by using shadow-4.0.11.1. But at least in the change

log, it has the erroneous messages bug as being corrected.

 

Any insight to my problem? 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/blfs-support/attachments/20050805/44d6bbc9/attachment.html>


More information about the blfs-support mailing list