grub errors and read-only

Declan Moriarty junk_mail at iol.ie
Fri Aug 5 08:37:34 PDT 2005


Recently, Somebody Somewhere wrote these words
> Hi there. I'm having serious problems since I put FC4 on my system which
> already has (B)LFS 6.0 and SuSE 9.1. I can't boot into SuSE or LFS at
> present. Actually, FC4 might not be the problem. I tried to put Sarge
> on /dev/hda which was a primary partition I made. I'm using the
[SNIP]

We accept the apology, you did go on a little. I snipped at what stood
out to me.

> I tried to put Sarge
> on /dev/hda which was a primary partition I made.

This may have been a typo, but as you probably know, it goes like this:

/dev/hda: (with it's own boot record).
Underneath this you have
	/dev/hda1 (first partition, with another boot record).
	/dev/hda2, etc etc.

The system boots off /dev/hda1, not /dev/hda. Hda refers to all the
drive.

That partition should  have been /dev/hda<something>, not /dev/hda.
(Guess who's been here before). To prevent this, you might do as I did
when I finally got going
dd if=/dev/hda of=/boot/hdabootnow bs=512 count=1
dd if=/dev/hda of=/boot/hda1bootnow bs=512 count=1

Then you can screw up as often as you like and save your dignity
silently by reversing the dd from some rescue disk.

So I'm adding: Sarge, + Suse, + Fedora, + Swap, + LFS + boot (and you
probably need that)= 5 or 6

You have hda1, hda2, hda3, & hda4 = 4 partitions.

I prefer a straightforward setup. I can give windows hda1, boot hda2,
swap hda3, and the rest to hda4 which becomes an extended partition, and
is never addressed or mounted.

Then you can have hda5 --> without headache. hda5 is always the 1st
partition in the extended drive.

What happened? My guess is that you haven't kept all your fstab files up
to date, you have imagined you had an extra partition and tried to
install onto it. See what's left.


--

	With best Regards,


	Declan Moriarty.



More information about the blfs-support mailing list