grub errors and read-only

Donal Farrell vmlinuz101 at gmail.com
Sat Aug 6 04:24:39 PDT 2005


I tried copying EVERYTHING from SuSE's /boot (except the grub folder)
into FC4's /boot. I am certain SuSE is on a reiser fs and FC4 is on
ext3 (shouldn't there at least be reiserfs in FC4 at this stage). I
take it ext3 has problems with reiserfs and therefore tried to mount
suse on  an ext2 fs. The kernel panic bit shows that it is trying to
kill init. The initrd it uses I'm not sure. There are several in the
SuSE /boot (now in FC4). I googled for the default fstab and menu.lst
options for SuSE9.1

title suse-2.6.4
root (hd0,(x-1))
kernel /boot/vmlinuz-2.6.4-52-default root=/dev/hda(x) vga=0x31a
splash=silent desktop resume=/dev/hda(y) showopts ro
initrd (hd0,(x-1))/boot/initrd

Mine is totally different at the moment, so I'll try point it to a
2.6.4-52_smp kernel and the corresponding initrd. By the way, the suse
kernel did get past the stage of setting up disks, io, etc. before
kicking out with the panic message

Donal



More information about the blfs-support mailing list