grub errors and read-only

Ken Moffat ken at kenmoffat.uklinux.net
Sat Aug 6 10:44:38 PDT 2005


On Sat, 6 Aug 2005, Donal Farrell wrote:

> Thanks Ken, this seems to have worked. suse reports on its boot that
> it can't find /etc/mtab, also, there is a fatal X server error, as it
> can "find the screen(s), but none are usable" I tried a startx, an int
> 5, etc., but no luck. Also, I'm using an nvidia driver (from about
> last march) and I'm wondering if that had anything to do with it???
>

 I assume you really are in suse now ? /etc/mtab has at times in the
past been a symlink to /proc/mounts, which will fail if /proc isn't
mounted.  Dunno if that's relevant or not.

 The screens problem can be caused by a misconfigured X.  But, the
nvidia driver might be the problem - if it isn't built (well, actually,
that's "wrapped") for the exact kernel, it probably ain't gonna work.
If in doubt, look at X's log to see if it can point you in the right
direction.

> Thanks a million for all your help too.
>

 Don't mention it.  The messing with suse is just your try-out so you
can boot your LFS system again :)  Once you understand how your systems
fit together, you can then go on and make backups.  After that,
repartition if you are going to.

Ken
-- 
 das eine Mal als Tragödie, das andere Mal als Farce




More information about the blfs-support mailing list