Can't mount with automount

Dienadel no at use.this.es
Wed Aug 10 12:59:54 PDT 2005


Andrew Benton wrote:

> Dienadel wrote:
>> 1- In the init process:
>> EXT3 FS on hda5, internal journal
>> EXT3-fs: mounted filesystem with ordered data mode.   [OK]
>> /etc/rc.d/rcsysinit.d/S45autofs: line 110: boot_mesg: command not found
>> .
> 
> Perhaps you're trying to use a new version of BLFS with an old version of
> the LFS bootscripts?

Yes, it was it. I've already used BLFS-6.0-bootscripts, and, now is ok


>> Bringing up the loopback interface...
>> RTNETLINK answers: File exists        [FAILED]
>> 
> 
> That looks familiar. Edit /etc/rc.d/init.d/localnet and rearrange the
> order of lines 22 and 23 so it reads
> 
> ip addr add 127.0.0.1/8 label lo dev lo
> ip link set lo up

Solved again. Perfect now

>  
>> 2- In "/var/log/daemon.log:
>> Aug 10 16:52:41 IUS2001 automount[3217]: >> mount: Not a directory
>> Aug 10 16:52:41 IUS2001 automount[3217]: failed to mount /media/cdrw
>> 
> 
> I don't know what the problem is. I've never used automount. I used to use
> the supermount patch but it was a pain to keep it in sync with the kernel.
> Now what I do is I put these lines in /etc/fstab
> 
> /dev/sda1 /mnt/mp3 auto defaults,user,noauto 0 0
> /dev/fd0 /mnt/floppy auto defaults,user,noauto 0 0
> /dev/hdc /mnt/cdrom auto defaults,user,noauto 0 0
> 
> In Gnome, when I run Nautilus in browser fashion it has a computer icon on
> the toolbar. If I click on it it shows me floppy, CD-ROM and mp3. If I
> click on them it mounts it and then shows the contents. To unmount it I
> right click and choose Unmount Volume before removing it. This works with
> a vanilla kernel and no automount daemon running. HTH

I wouldn't have any problem using this way. I don't mind mount and umount in
KDE. But, idon't want my pather do that. The mount and umount would be
automatic.

By the way, i have recompiled the kernel with NFS and SMB support, and the
problem persists.

The strange thing, is that when i began to build BLFS, i probed automount to
test it, as i didn't want to depend of an external patch. And it worked!!
but, now, i don't know why, it doesn't.



More information about the blfs-support mailing list