Firefox error to install

Richard A Downing richard at langside.org.uk
Sun Aug 14 23:45:47 PDT 2005


mlij wrote:
> Hi everyone!
> 
> There was not any error to install it.
> When the BLFS 6.0 asks to run firefox in the /usr/bin, there is a failure:
> 
> root@[lfs]:/usr/bin# firefox
> *** nsExtensionManager::_disableObsoleteExtensions - failure, catching
> exception so finalize window can close
> /usr/lib/firefox-1.0.6/run-mozilla.sh: line 159: 25954 Segment Fault   
> "$prog" ${1+"$@"}
> 
> 
> I downloaded the version 1.06 (I changed the commands from 1.0 to 1.06)
> 
> What happened?
> 
> Mlij
> 

This happens on the initial run of firefox as root if the font system is
not properly installed.  The firefox initialization system is trying to
put up a message to say that it is deleting your old extensions (from
the previous installation, if you have one), but can't, as the font
files are not accessible.

Make sure you have the X11 font system set up and re-read the BLFS pages
on  X Window System Components.

Richard.



More information about the blfs-support mailing list