No sound

randhir phagura rsphagura at hotmail.com
Mon Aug 15 18:43:06 PDT 2005


Hi,

Thanks for your responses and tips. I did all that. The summary is as below:

Randy wrote:

>I always ensure that the ALSA 'aplay' command will play a .wav >file...
>What happens when you use the speaker-test program as the root user?

The 'aplay' command output:

root at homelfs6:~# aplay /usr/share/sounds/alsa/Noise.wav
Playing WAVE '/usr/share/sounds/alsa/Noise.wav' : Signed 16 bit Little 
Endian, Rate 48000 Hz, Mono

root at homelfs6:~# aplay /usr/share/sounds/alsa/Front_Left.wav
Playing WAVE '/usr/share/sounds/alsa/Front_Left.wav' : Signed 16 bit Little 
Endian, Rate 48000 Hz, Mono
(NO SOUND IS HEARD IN BOTH CASES)

root at homelfs6:~# speaker-test

speaker-test 0.0.8

Playback device is plughw:0,0
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 32 to 16384
Period size range from 32 to 16384
Periods = 4
Buffer time size 2525
To choose buffer_size = 15052
To choose period_size = 3763
was set period_size = 3763
was set buffer_size = 15052
0 - Front Left
Time per period = 2.666857
0 - Front Left
Time per period = 2.978476
0 - Front Left
Time per period = 2.978524
(This Keeps repeating till 'CTRL+C'- NO SOUND IS HEARD

Jeremy wrote:

>Did you run alsamixer and unmute the master/pcm/etc.. devices?

I had not done that. The summary of the alsamixer ncurses output is:

1.Playback View:
Master:'MO'; 3D Contr:'OO' ; PCM & PCM1:Volume bar shows green ;
Mic Boos:'OO' ; PC Speak: Bar green ; Hardware:'OO' ; Record: 'OO'

2.Capture View:
Master:---- ; Mic: 'CAPTURE' 'L R' ; Capture: 'CAPTURE' 'L R'

3.All View: Same as above.
In 'Master' one channel always stays muted, inspite of repeated toggling. 
This happens in all the views.

Eric wrote:

>if you still can not hear anything from xmms, press 'Ctrl+P' to >change 
>configuration of xmms.
>try to set the 'Output Plugin' to 'ALSA...' or 'OSS..'.

Did that now Eric. I have configured both ALSA and OSS. Left the default 
settings mostly except where I could make out or guess the meaning 
correctly.

The 'xmms' does not work still. On clicking at the play button it promptly 
displaye the same dialogue: "Please ensure that: Your sound card is 
configured .... etc etc."

Randhir Phagura

_________________________________________________________________
See him in the ‘mustached’ avatar in Mangal Pandey. 
http://server1.msn.co.in/SP05/Mangalpandey/index.html Click here to know all 
about the movie.




More information about the blfs-support mailing list