PHP does NOT like our 'Apache' install

randhir phagura rsphagura at hotmail.com
Fri Aug 19 19:12:47 PDT 2005


Hi,

I am following the Book BLFS-Version-svn-2005081 on Pentium-III.
I generally install such applications in /opt in their respective 
directories, because it becomes easier to update. The /etc/ld.so.conf is 
updated and the essential items are linked into /usr.

PHP-5.0.4 is being installed in '/opt/php'. 'Apache' is an essential 
dependency of PHP.
Apache has been installed without any problem in '/opt/apache' and 
'/opt/sbin/apxs' was linked into '/usr/sbin'. 'ldconfig' was run after 
updating '/etc/ld.so.conf'. The new PATH was exported and includes 
'/opt/apache/bin'. But PHP is not satisfied.

During PHP 'configure', as per the Book, the following error was reported:

Configuring SAPI modules
checking for AOLserver support... no
checking for Apache 1.x module support via DSO through APXS... no
checking for Apache 1.x module support... no
checking for mod_charset compatibility option... no
checking for Apache 2.0 filter-module support via DSO through APXS... no
checking for Apache 2.0 handler-module support via DSO through APXS...
Sorry, I cannot run apxs.  Possible reasons follow:
1. Perl is not installed
2. apxs was not found. Try to pass the path using --with-apxs2=/path/to/apxs
3. Apache was not built using --enable-so (the apxs usage page is displayed)
The output of apxs follows:
./configure: line 5467: apxs: command not found
configure: error: Aborting
root at homelfs6:/p/php-5.0.4#

Now, I checked in '/opt' with the 'find' command but there is no 'apxs2'. 
There is only '/opt/apache/sbin/apxs'.

I reinstalled 'apache' with '--enable-so' option (as PHP suggests) even 
though the BOOK does not say so. Still did not find 'apxs2'; only 'apxs'.

On including '--with-apxs=/opt/apache/sbin/apxs' option for PHP 'configure' 
it gives the following error:

Configuring SAPI modules
checking for AOLserver support... no
checking for Apache 1.x module support via DSO through APXS... configure: 
error: You have enabled Apache 1.3 support while your server is Apache 2.  
Please use the appropiate switch --with-apxs2
root at homelfs6:/p/php-5.0.4#

PHP does not seem to be happy with our install method of 'apache-2.0.54'??

Regards,

Randhir Phagura

_________________________________________________________________
Enjoy Austria. http://www.coxandkings.com Only with Cox & Kings




More information about the blfs-support mailing list