DocBook_DSSSL_Stylesheets

Harris Christian D SSgt 1 CS/SCBAM Christian.Harris at langley.af.mil
Fri Aug 19 21:39:53 PDT 2005


I finished installing DocBook_DSSSL_Stylesheets. Previous to that I

 statisfied the required and optional dependencies listed on the page.

 When I run the test I get the following errors.

 

onsgmls -sv test.sgm

onsgmls:I: "OpenSP" version "1.5.1"

onsgmls:test.sgm:1:61:W: cannot generate system identifier for public
text "-//Davenport//DTD DocBook V3.0//EN"

onsgmls:test.sgm:1:61:E: reference to entity "CHAPTER" for which no
system identifier could be generated

onsgmls:test.sgm:1:0: entity was defined here

onsgmls:test.sgm:1:61:E: DTD did not contain element declaration for
document type name

onsgmls:test.sgm:2:8:E: element "CHAPTER" undefined

onsgmls:test.sgm:2:15:E: element "TITLE" undefined

onsgmls:test.sgm:3:5:E: element "PARA" undefined

 

openjade -t rtf -d
/usr/share/sgml/docbook/dsssl-stylesheets-1.79/print/docbook.dsl
test.sgm

openjade:test.sgm:1:61:W: cannot generate system identifier for public
text "-//Davenport//DTD DocBook V3.0//EN"

openjade:test.sgm:1:61:E: reference to entity "CHAPTER" for which no
system identifier could be generated

openjade:test.sgm:1:0: entity was defined here

openjade:test.sgm:1:61:E: DTD did not contain element declaration for
document type name

openjade:test.sgm:2:8:E: element "CHAPTER" undefined

openjade:test.sgm:2:15:E: element "TITLE" undefined

openjade:test.sgm:3:5:E: element "PARA" undefined

 

openjade -t sgml -d
/usr/share/sgml/docbook/dsssl-stylesheets-1.79/html/docbook.dsl test.sgm

openjade:test.sgm:1:61:W: cannot generate system identifier for public
text "-//Davenport//DTD DocBook V3.0//EN"

openjade:test.sgm:1:61:E: reference to entity "CHAPTER" for which no
system identifier could be generated

openjade:test.sgm:1:0: entity was defined here

openjade:test.sgm:1:61:E: DTD did not contain element declaration for
document type name

openjade:test.sgm:2:8:E: element "CHAPTER" undefined

openjade:test.sgm:2:15:E: element "TITLE" undefined

openjade:test.sgm:3:5:E: element "PARA" undefined

 

The files produced (jtest.rft test.rtf c1.htm) are still produced. I can


open all three files, and they are just differently formatted test 

pages. They look correct (as far as I can tell). I think something 

is misconfigured (though I copy and pasted all directions from 

the book). Where did I go wrong? 

 

What's with the reference to DocBook V3.0 in the errors? The 

only version on my system is 4.4

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/blfs-support/attachments/20050820/202459fe/attachment.html>


More information about the blfs-support mailing list