Firefox error to install

Christopher Beppler lfs at funzi.de
Sun Aug 21 10:01:45 PDT 2005


Randy McMurchy wrote:
> Christopher Beppler wrote these words on 08/21/05 11:38 CST:
>
>
>>Id did exactly the same (using LFS and BLFS 6.1) using both Xorg and
>>XFree (not at the same time) but it doesn't work already...
>>
>>What should I try now?
>
>
> Be more verbose in the description of your problem ("but it doesn't
> work already" is not very helpful).

Sorry...

root at opteron:~# uname -a
Linux opteron 2.6.12.3 #18 SMP Fri Jul 22 18:17:26 CEST 2005 i686
athlon-4 i386 GNU/Linux

you see... It's a i686-pc-linux-gnu

I have installed now XFree86-4.5.0 following the instructions of BLFS 6.1.

If I want to start firefox for the first time, I get the following error:

root at opteron:~# LC_ALL=C firefox
/usr/lib/firefox-1.0.6/run-mozilla.sh: line 159:  3833 Segmentation
fault      "$prog" ${1+"$@"}

I have started fc-cache a lot of times...
root at opteron:~# fc-cache -v
fc-cache: "/usr/X11R6/lib/X11/fonts": skipping, 0 fonts, 11 dirs
fc-cache: "/usr/X11R6/lib/X11/fonts/local": skipping, 0 fonts, 0 dirs
fc-cache: "/usr/X11R6/lib/X11/fonts/encodings": skipping, 0 fonts, 1 dirs
fc-cache: "/usr/X11R6/lib/X11/fonts/encodings/large": skipping, 0 fonts,
0 dirs
fc-cache: "/usr/X11R6/lib/X11/fonts/util": skipping, 0 fonts, 0 dirs
fc-cache: "/usr/X11R6/lib/X11/fonts/misc": skipping, 55 fonts, 0 dirs
fc-cache: "/usr/X11R6/lib/X11/fonts/75dpi": skipping, 398 fonts, 0 dirs
fc-cache: "/usr/X11R6/lib/X11/fonts/100dpi": skipping, 398 fonts, 0 dirs
fc-cache: "/usr/X11R6/lib/X11/fonts/cyrillic": skipping, 0 fonts, 0 dirs
fc-cache: "/usr/X11R6/lib/X11/fonts/Speedo": skipping, 0 fonts, 0 dirs
fc-cache: "/usr/X11R6/lib/X11/fonts/Type1": skipping, 29 fonts, 0 dirs
fc-cache: "/usr/X11R6/lib/X11/fonts/CID": skipping, 0 fonts, 0 dirs
fc-cache: "/usr/X11R6/lib/X11/fonts/TTF": skipping, 22 fonts, 0 dirs
fc-cache: "/usr/share/fonts": no such directory, skipping
fc-cache: "/root/.fonts": no such directory, skipping
fc-cache: "/usr/X11R6/lib/X11/fonts/TTF": skipping, 22 fonts, 0 dirs
fc-cache: "/usr/X11R6/lib/X11/fonts/Type1": skipping, 29 fonts, 0 dirs
fc-cache: succeeded

and my /etc/fonts/local.conf contains:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/local.conf file for local customizations -->

<fontconfig>
<dir>/usr/X11R6/lib/X11/fonts/TTF</dir>
<dir>/usr/X11R6/lib/X11/fonts/Type1</dir>
</fontconfig>

I am sure, that I have misconfigured the fonts. But what is my fault.
I've done everything like described in "X Window System Components" from
BLFS 6.1

Christopher
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: OpenPGP digital signature
URL: <http://lists.linuxfromscratch.org/pipermail/blfs-support/attachments/20050821/e06841b6/attachment.sig>


More information about the blfs-support mailing list