'Compiler cannot create executables'

Declan Moriarty junk_mail at iol.ie
Mon Aug 22 06:10:14 PDT 2005


Recently, Somebody Somewhere wrote these words
> On Sun, 21 Aug 2005, Cliff McDiarmid wrote:
> 
> >
> >>On Sun, 21 Aug 2005, Ken Moffat wrote:
> >
> >>  Wow, that's quite a mixture of places on your PATH, Cliff.
> >>My first guess is that you've perhaps got multiple versions of one
> >>or more or gcc and binutils, and setting the PATH like this is
> >>mixing them up?
> >
> >No, I've only got one version of each and the odd thing is that the
> >gcc was working one minute and not the next. I was trying to clean
> >the system by deleting unwanted programs and this is why I feel i
> >might have deleted an important component of gcc.  Is this possible?
> >
>  Definitely.  The gcc programs in /usr/bin are obviously still there,
>  how about the contents of /usr/lib/gcc ?
> 
>  Do you have backups in a form where you can see what used to be in
>  /usr ?  If you don't, this is all rather academic.  If you do,
>  compare /usr/bin, /usr/lib and its subdirectories, /usr/sbin, and
>  /usr/libexec if there was one.
> 
> Ken -- das eine Mal als Tragödie, das andere Mal als Farce


Have you decided what version of gcc you are usiong, and taken steps to
see that

	a. the compiler in question sees the right versiuon of libs?
	b. all paths, etc lead to that compiler.

I've been here, done this with gcc-3.3.1 & gcc-2.95.3. Choose your
favourite compiler; set $CC $CXX $CPP & $PATH appropiately. Set
/etc/ld.so.conf and rerun ldconfig. I ran for a while here with
gcc-2.95-3 first in the path (/usr/bin) and gcc-3.3.1 in /usr/local/bin.
I normally selected gcc-3.3.1 with $CC, $CXX, & $CPP, but would unset
them to use gcc-2.95-3. Libraries looked after themselves, but I would
make sure to have your FHS compatible locations listed before your
exotic ones. Mind you, I never tried multiple versions of binutils. You
are on your own there.

-- 

	With best Regards,


	Declan Moriarty.



More information about the blfs-support mailing list