X.org executable not produced

David Ciecierski davidcie at klub.chip.pl
Thu Aug 25 15:37:05 PDT 2005


Still no success - but I discovered that even the Xorg executable is not 
installed, it does get built. I run make install in 
xcbuild/programs/Xserver and I had Xorg under /usr/X11R6/bin. However, 
trying to execute Xorg -config resulted in Xorg complaining about 
missing bitmap module... which probably refers to bitmap fonts. As 
mentioned earlier, I wanted as slim a build as possible and disabled 
font support for everything but freetype:

#define BuildSpeedo			NO
#define BuildCID			NO
#define BuildFreeType			YES
#define BuildSpeedoFonts		NO
#define BuildCIDFonts			NO
#define BuildCyrillicFonts		NO
#define Build75DpiFonts			NO
#define Build100DpiFonts		NO
#define BuildType1Fonts			NO
#define BuildTrueTypeFonts		YES

So: is it possible to run X's with *only* freetype? I'll probably try 
enabling bitmap fonts to see...

Regards,
David Ciecierski



More information about the blfs-support mailing list