firefox-1.0.6 & gtk+2.8.0

frank frank at xeen.net
Fri Aug 26 07:55:36 PDT 2005


hi!

i dont get firefox-1.0.6 starting up. i have gtk+2.8.0/2 which needs 
cairo and pango with cairo support installed.

it starts (which is known and ok according to former posts):
*** nsExtensionManager::_disableObsoleteExtensions - failure, catching 
exception so finalize window can close

it ends up in an infinite loop:
*** loading the extensions datasource

in addition there are lots of gdk warnings (also repeated):

(firefox-bin:2021): Gdk-CRITICAL **: gdk_drawable_get_colormap: 
assertion `GDK_IS_DRAWABLE (drawable)' failed

(firefox-bin:2021): Gdk-WARNING **: gdk_window_set_back_pixmap(): pixmap 
must have a colormap

i am pretty sure this is not a font problem. i also tried deleting  
~/.firefox and ~/.mozilla directories. this doesnt solve the problem. 
any ideas what i am doing wrong? i am not quite sure if it's a problem 
with latest gtk, all other gtk apps seem to work fine.

thanks for suggestions, frank.

ps:

firefox was built with corrected default-mozilla-five-home dir.

i uploaded some log files:
http://www.physik.uni-augsburg.de/~zirkelfr/download/lfs/firefox.log
http://www.physik.uni-augsburg.de/~zirkelfr/download/lfs/gtk+.log
http://www.physik.uni-augsburg.de/~zirkelfr/download/lfs/pango.log
http://www.physik.uni-augsburg.de/~zirkelfr/download/lfs/cairo.log




More information about the blfs-support mailing list