Anyone can explain DVD writing to me ?

Declan Moriarty junk_mail at iol.ie
Tue Aug 30 04:25:46 PDT 2005


Recently, Somebody Somewhere wrote these words
> Le Mon, 29 Aug 2005 16:28:52 +0100 Declan Moriarty <junk_mail at iol.ie>
> a écrit :
> 
> > Recently, Somebody Somewhere wrote these words
> > > Hi my dear LFS users friends.
> > > 
> > > What are the stages to enable a ND-3500AG NEC DVD writer ?
> > > 
> > > \bye
> > > 
> > 
> > Stage 1:  READ!
> 
> Ah... yes, thank you for the advice. I've been reading for about a
> week now, searching intensively the net, books, magazines...
> Maybe I could restate my question : do you now ANY link putting all
> this together ?
Switching google's advanced search from "Anywhere in the page" to "In
the title of the page" you get links from


http://www.dvd-recordable.org/
http://www.dvdr-digest.com/
http://comparedvdsoftwareburn4free.com/

I should explain I work in Electronics, and have been continually
frustrated by others finding things I cannot. Often it's stupoid things
like pages that say they're in French when they actually are English,
and I specifying "English" as the language. Sometimes you just have to 
use the tools properly.

> 
> To complete my question, because I can see you quite dislike those
> lazy short messages :
> 
> 1) devices : when you compile ide-scsi module on a brand new 2.6
> kernel, you are beeing mocked at because this is old fashion, ide-cd
> being much more "modern". But when you read the cdrecord, dvd+rx+tools
> and other help pages, it is said that this is not so good, especially
> from the performances point of view. And there is the udev settings
> problem, of course... See what I mean ?
The biggest hitch with ide-scsi is /etc/fstab, IIRC. You have to select
it as ide-scsi, enable writing, and have udf(?), ide-scsi, generic scsi,
and probably more available to the kernel.
> 
> 2) I tried Xcdroast, but it needs a special (and non free) cdrecord
> version to burn DVDs... no good.
> 
> 3) I tried K3b... and was stuck by foolish things like k3bsetup not
> finding "su" in my path. I ran it from root, but was unable to get a
> real burning operation. Everything works fine unitl it tries to burn,
> and then there is a seeking error... (all this in ide-scsi mode).

This you can probably fix. A lot of things reduce the path to
"/bin:/usr/bin;" I have also seen "/usr/bin:/usr/sbin;"No doubt it's a
security ploy but actually ends up being a pain in certain
circumstances. Try this

grep PATH /etc/* |less
grep PATH ~/* <as your cdwriting user>
grep PATH ~/.*

BTW, I have 'su' in /bin. Where is yours?

You will probably need the 'less' bit. I would advise against using the
-r option on grep for /etc!

You are nearly there with this one. Turn up debugging and check your
logs. Another thing to beware of is that if something wants to be a
user, and you run it as root, it may well fall back to being 'nobody'
the most useless of lusers. Read the small print with this package.

> 
> 4) I tried to compile the gnome dvd-burning project, but got bored by
> all the dependencies :-(
Gnome appears to be dependancy Hell.
> 
> 5) Of course, I started with some console tries, but this got me
> nowhere :

Doesn't mkisofs do it? One thing you can do, btw, is make up your iso as
a block file and then mount it to check it.
> 
> > Then you can fill in the remaining stages yourself. Grep the blfs
> > book
> > 
> > grep -ir dvd *
> 
> Yes, I did something like this. I'm not COMPLETLY stupid, you know
> (QUITE, but not COMPLETLY) ;-) 


Thank you for restoring our confidence in your hard work and diligence.

> 
> > www.google.ie/linux & search term dvd writing
> 
> Well, this is the good news from your message : I didn't know this
> special section from Google. So your insults were justified, after all
> :-) I saw a few more links that I will consult, and then I'll annoy
> you a little more, I guess ;-)
> 
I haven't sorted this myself, you know. I mean to buy a cd or dvd writer
but it just never happened. The last one was robbed and returned
_with_5V_applied_ blowing it and a Southbridge :-O. Kids....grrr.

-- 

	With best Regards,


	Declan Moriarty.



More information about the blfs-support mailing list