GTK configure fails on ATK check

David Ciecierski davidcie at klub.chip.pl
Wed Aug 31 18:17:49 PDT 2005


Yes, it's me once again buggering all of you... A little update for 
those who read some of my previous: I've uninstalled almost all packages 
relating in any way to Gnome (down to Gtk, libIDL, libarl, etc.) and are 
now happily recompiling them + spying on each and every *.err produced 
(pkg-user hint).

It's been great until now: GTK+ (2.8.3, but I also tried 2.8.2 that 
worked well the first time) configure fails on the following check 
(pasted from configure.in):

[code]
         AC_TRY_LINK_FUNC(atk_object_get_type, : , AC_MSG_ERROR([
	*** Cannot link to Accessibility Toolkit. Accessibility
	*** Toolkit is required to build GTK+]))
[/code]

I rebuilt ATK twice, after installing Cairo and Pango. I also rebuilt 
Pango for good measure, but apparently all this didn't impress GTK 
config script. I'm not sure why it complains about the above - is it 
missing libraries? Could it be that I'm using ATK 1.10.2 instead of the 
1.10.1 I used before? Why should it fail if it's listed on GTK website? 
Ehhhh.

Thanks in advance, as always...
Kind regards,
David Ciecierski



More information about the blfs-support mailing list