Building RPM

Tarek Ghaleb turmeric2005 at cairo.ws
Mon Jul 25 12:30:47 PDT 2005


Hi all,

I'm trying to build rpm-4.4.2 using the rpm hint. I'm using blfs
cvs-2005-07-20 version of the book. I've built all required
dependencies but when I run:

  $ ./configure --prefix=/usr --enable-posixmutexes --without-selinux \
                --without-python --without-javaglue 

It fails with:

  ...
  configure:33751: checking "rpcgen -C" build of db_server.h 
  configure:33755: result: no
  configure:33760: checking "rpcgen" build of db_server.h
  configure:33764: result: no
  configure:33766: error: Unable to build RPC support: rpcgen failed.
  ...

Since this was happening with the configure script in the db3 directory,
I thought I'd try to rebuild Berkeley DB-4.3.28 with --enable-rpc. I
added this switch to the ./configure command but also got the
same exact error as above.

Aren't the rpc libraries a part of glibc--I'm using glibc-2.3.4--or am I
missing some other libraries/dependencies?

Tarek

-- 
"Oh, how fine it is to know a thing or two." - Moliere



More information about the blfs-support mailing list